5E Storm Kings Thunder Playlist
Page 1 of 2 12 Last
  1. #1

    FGU not starting on Linux

    I just bought and downloaded FGU on Steam.

    If I press PLAY, I get the following message:

    FGUSteamLauncher
    /home/xxxxxxxxxx/.smiteworks/fantasygrounds/-FantasyGroundsUpdater not found

  2. #2
    Zacchaeus's Avatar
    Join Date
    Dec 2014
    Location
    Scotland
    Posts
    17,285
    What version of Linux are you using?
    If you need to contact customer support or if there is something that you would like to see in Fantasy Grounds that isn't currently part of the software or if there is something you think would improve a ruleset then add your idea here http://fgapp.idea.informer.com/

  3. #3

  4. #4
    wndrngdru's Avatar
    Join Date
    Jun 2015
    Location
    US, Central (UTC -6 or -5)
    Posts
    248
    While Pop! is not officially supported, you might be able to get it to work (especially if it uses Ubuntu as a base, I'm not familiar with Pop!).
    The steam installer is just a wrapper for the same exact program you can download from this site. You might try installing it using the installer from the homepage. Then, get your license key from steam and input that in the updater when it asks for it.
    --
    I'm so bassic

  5. #5
    That did work. This means that the Steam installer is borked. Can you please fix it so I don't have to have this install by itself? I bought it through Steam on purpose because I wanted it managed under my Steam library.

  6. #6
    Zacchaeus's Avatar
    Join Date
    Dec 2014
    Location
    Scotland
    Posts
    17,285
    All steam does is create a shortcut to the client.exe file, so the install is always vi the Smiteworks site. You should be able to activate a product on steam via the game menu if you want it to appear on steam.
    If you need to contact customer support or if there is something that you would like to see in Fantasy Grounds that isn't currently part of the software or if there is something you think would improve a ruleset then add your idea here http://fgapp.idea.informer.com/

  7. #7
    The game is already in my Steam library. I attempted to install through Steam. The Steam installer did not work. You guys then told me to download the installer through your site instead. I should not have to go to a third party site to download games that are on Steam. This means that your installer is broken and should be fixed.

  8. #8
    damned's Avatar
    Join Date
    Mar 2011
    Location
    Australia
    Posts
    24,063
    Blog Entries
    1
    As per the Steam website:

    MINIMUM:
    Requires a 64-bit processor and operating system
    OS: Ubuntu 16.04+
    Processor: 1.6 GHz or higher processor (SSE2 instruction set support)
    Memory: 4 GB RAM
    Graphics: Graphics card with DX10 (shader model 4.0) capabilities.
    Network: Broadband Internet connection
    Storage: 2 GB available space
    Sound Card: A sound card is required for voice communication using external programs like Google Hangouts, Skype or Discord and for dice sounds.

    MoreCore - Generic Ruleset
    --- Projects ---
    Extensions | Tutorials | MoreCore | MoreCore Themes | Call of Cthulhu | Maelstrom | FG Con

  9. #9
    Directly from the Github repo:

    Pop!_OS is designed for people who use their computer to create; whether it’s complicated, professional grade software and products, sophisticated 3D models, computer science in academia, or makers working on their latest invention. The Pop! user interface stays out of the way while offering extensive customization to perfect your work flow. Built on Ubuntu, you have access to vast repositories of open source software and development tools.


    I understand you guys are not qualified to deal with this issue, can you please raise an internal ticket and kick it to whichever dev was tasked with doing Linux support? Your installer really is broken, it's not that I'm on some outlandish Linux distro that was a real gamble whether it would work.
    Last edited by Vlek; July 17th, 2021 at 05:49.

  10. #10
    LordEntrails's Avatar
    Join Date
    May 2015
    Location
    -7 UTC
    Posts
    14,479
    Blog Entries
    9
    No we can not raise an internal ticket. We are simply users like you who try to help other users. If you would like to reach out to SmiteWorks directly their is a link at the top of the forums called "Help". Under that is "Contact Support". You may open your own ticket there.

    To reiterate, Steam works fine for users on supported platforms, like Ubuntu. Pop! may be built on ubuntu, but it is not Ubuntu so it is not officially supported, but SmiteWorks might be able and willing to get the Steam installer to work on Pop! or they might be able to tell you why it doesn't.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
FG Forge

Log in

Log in