SWADE Playlist
Page 1 of 9 123 ... Last
  1. #1

    Intermittent Halting / Freezing / "Not Responding" Messages

    Whenever my SO hosts a game (campaign created in FGU, current version of LIVE for 5E, only extension installed is Theogeek's Improved critical but was having issues before that), they are plagued with the game halting on them, like once every 10 or so minutes, usually when they are attempting to do something like roll dice, create a wall/light, load an image, drop a token onto the map. Campaign file (db.xml) isn't that large either, just 2.12mb, no issues when using the campaign on my computer.

    We're keeping an eye on the system usage and not seeing anything crazy, but OneDrive was running, so we'll closed that but were still having issues. Ended up closing everything, restarting, then having only Fantasy Grounds running and still having issues. System specs:

    OS Name Microsoft Windows 10 Home
    Version 10.0.19041 Build 19041
    Processor Intel(R) Core(TM) i7-9750H CPU @ 2.60GHz
    Total Physical Memory 15.8 GB
    Available Physical Memory 7.52 GB
    Graphics NVIDIA GeForce RTX 2070

    At one point they were just idle and it went "not responding" again. Checked memory and Fantasy Grounds was using 2.2GB. Nothing "crazy" resource usage from what we can see, 30% CPU usage. Happens the most when they host, but happens in games others host as well, but not as often, usually just annoying enough that it'll be "roll a save" then we have to wait an extra minute or two for the game to process the roll.

    Tried lowering the framerate and imagequality through the commands, but doesn't seem to help at all. Tried the settings clear, too. Was thinking about the vault clear, but the website said that generally it's not needed and should only do it if staff recommends, so I'll hold off on that. Attaching logs.
    Attached Files Attached Files
    Last edited by allpraisethedm; May 22nd, 2021 at 03:49.

  2. #2
    Someone asked in the Discord if we're using wireless and yes, they are, and now I feel like a baboon for not thinking of trying that sooner, but here we are. Still, even if the bandwidth or latency is a bit worse off with WiFi, should that be causing the application to go "Not Responding" every once in awhile?

    Edit: And... while it's immediately appearing to be less frequent, still getting "Not Responding" while on Ethernet.
    Last edited by allpraisethedm; May 21st, 2021 at 23:52.

  3. #3
    LordEntrails's Avatar
    Join Date
    May 2015
    Location
    -7 UTC
    Posts
    14,481
    Blog Entries
    9
    How many modules are loaded? Does this happen when they open a list like Items? Does it happen when they open the actions tab on a character for the first time? Are they adding LOS and/or lights while combat tokens are on the map?

  4. #4
    Quote Originally Posted by LordEntrails View Post
    How many modules are loaded? Does this happen when they open a list like Items? Does it happen when they open the actions tab on a character for the first time? Are they adding LOS and/or lights while combat tokens are on the map?
    They have all the source books (PHB, MM, Tasha's, Volo's, etc.) and the Against the Giants module. It can happen when doing all of those things, but also sometimes, like right now while we're playing, they're typing something into the chat box to be translated into Giant speak.
    Last edited by allpraisethedm; May 22nd, 2021 at 02:27.

  5. #5
    It sounds like it could be a performance issue with specific map data.

    When the rolls slow down, have you tried closing all the open maps and see if it gets better? (Points to a map performance issue)
    What maps do you have open when you see the issue?
    How was the LoS and lighting applied to the map?
    How many tokens are on the map?
    What is the resolution of the screen being used to display the map; and is the map in the background or in a floating window?

    If it's a specific campaign and set of images, you can try zipping up the campaign folder, and providing it to us along with the steps to see the issue.

    Regards,
    JPG

  6. #6
    Quote Originally Posted by Moon Wizard View Post
    When the rolls slow down, have you tried closing all the open maps and see if it gets better? (Points to a map performance issue)
    What maps do you have open when you see the issue?
    How was the LoS and lighting applied to the map?
    How many tokens are on the map?
    What is the resolution of the screen being used to display the map; and is the map in the background or in a floating window?

    If it's a specific campaign and set of images, you can try zipping up the campaign folder, and providing it to us along with the steps to see the issue.
    Looking it over now and they do have a lot of large maps loaded into the campaign. Their entire images folder was about 400mb, so we cleaned that up, they images that we used previously.

    The issue also happens when no maps are open, but otherwise if there are maps, LoS and Lighting are added manually on their own layers. Generally only about 8 to 12 tokens on the map. Screen is 2560x1440 and sometimes the map is the back ground or sometimes floating, but like I said, sometimes no map is open and the application will stop responding.

    It definitely happens more when a good sized map (9900x12600, 9.3mb) with LoS and lighting are on and while it's open rolling dice every other time triggers a halt, but it's not exclusive to those situations.

    And "saying it outloud" now, that map size is massive, it's larger than even the ones I use for the DotMM, but again, issue can happen when the map isn't open, so I'm not sure if it's a map issue, just that having a big 'ole map takes even more resources.
    Last edited by allpraisethedm; May 22nd, 2021 at 04:04.

  7. #7
    Hard to tell without being able to recreate the specific scenario, and investigate. A map that large is probably going to have a lot of LoS and lighting going on; so possibly related just having it loaded in the campaign.

    As I mentioned, a specific example campaign we can use to investigate is really what we are after, because that let's us observe and investigate the issue, as well as test possible adjustments and fixes.

    Regards,
    JPG

  8. #8
    Quote Originally Posted by Moon Wizard View Post
    Hard to tell without being able to recreate the specific scenario, and investigate. A map that large is probably going to have a lot of LoS and lighting going on; so possibly related just having it loaded in the campaign.

    As I mentioned, a specific example campaign we can use to investigate is really what we are after, because that let's us observe and investigate the issue, as well as test possible adjustments and fixes.

    Regards,
    JPG
    Alrighty, yeah, we're beat for the day so gonna figure it out over the weekend. If we run into the issue again even after a cleanup, we'll compress it and I'll share it on my Goggle Drive, unless there's a better place to slap it.

  9. #9
    If a map is 'shared' , it does not mean the data is not being shared when minimized or closed. The map sizes, token sizes, content, lower bandwidth, and other factors all add up. The content needed to play are actually very minimal. The GM can deactivate all but the essential core books until level up or spell switching times. Find out how large the character's portrait photo is. I have had players using 800x800 pixel photos for that little 100x100 square box.

    Check or ask about system specs: (Suggested) https://www.systemrequirementslab.co...ds-unity/20349

    FG Classic Suggested Files sizes: https://fgc-kb.fantasygroundscollege...y-grounds-vtt/
    The suggested sizes are much 'safer' memory-wise, but not always needed. If you have a decent computer and you have a decent video card. Having a little bit larger or a medium sized,quality map, might be just be doable, provided you have the upload speed and bandwidth, and your players are similarly spec'd. 2000x2000 px is fairly large dimensionally. This also means tons of zooming and manual scrolling in a large map view window, which is horrible for game play and time. DotMM, that map was how it was provided to Smiteworks. I honestly would just use the main map as a GM reference map, and then just use the FGU Dungeon Tiles to reconstruct pieces of the dungeon as needed, and then just link these smaller self-made asset created battle-maps to the original module map.

    Best of Luck!
    Laerun
    Last edited by Laerun; May 22nd, 2021 at 07:16. Reason: spelling errors
    FGC (Fantasy Grounds College) Founder
    FGU teacher and student!
    Ultimate License Holder
    Discord Alias: Laerun
    FGC Team Member
    http://www.fantasygroundscollege.net

  10. #10
    Quote Originally Posted by Moon Wizard View Post
    Hard to tell without being able to recreate the specific scenario, and investigate. A map that large is probably going to have a lot of LoS and lighting going on; so possibly related just having it loaded in the campaign.

    As I mentioned, a specific example campaign we can use to investigate is really what we are after, because that let's us observe and investigate the issue, as well as test possible adjustments and fixes.

    Regards,
    JPG
    I apologize for not updating this sooner, but we left for a week for vacation, life, etc. I created a new campaign on their device but after the locking up occurred, I went back to the logs and noticed that the last few times that it locked up, it was right when the game was saving the campaign.

    So I tried uninstalling the game, then reinstalling it. Giving FantasyGrounds and FantasyGrounds Updater administrator rights, updating to the latest LIVE version, but still, getting lock ups. Go back to the logs and it just saved a moment ago. Since it's only happening on their device and not mine, it must be something weird with the Windows install or profile, I guess, but this is the only application they have an issue with.

    Or maybe the specific hardware that it has, I figured the specs would be more than good enough (mentioned in the OP) but maybe because it's a laptop it's doing something weird with the video drivers? Nvidia drivers are up to date and it's using the dedicated GPU with all default settings, so I'm not sure what to change there.

    I also created a completely new campaign and imported the previous characters into it, created a few new maps with the smaller images that they were using, threw a dragon into the combat tracker and started rolling dice back and forth, eventually locked up when trying to load dice: https://drive.google.com/file/d/19--...ew?usp=sharing
    Attached Files Attached Files

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Starfinder Playlist

Log in

Log in