5E Product Walkthrough Playlist
Page 1 of 3 123 Last
  1. #1

    5E Class Specialization Details

    I am new here and just this weekend purchased FGU including the core books: DMG, PHB, MM, Volos, and Xanathar. When I level-up a character to 3rd, in this instance a Ranger, I get some choices such as Gloom Stalker and others. However, I know diddly about what a Gloom Stalker offers, as with some others since I never owned Xanathar's before, but the character leveling process does not afford any details about these specializations that I can see or find. I can't believe I am left to just randomly choose one and then during play find out what is offered and where this specialization leads me. Where can I read the details of this specialization and the other choices? Thank you in advance.

  2. #2
    Zacchaeus's Avatar
    Join Date
    Dec 2014
    Location
    Scotland
    Posts
    16,358
    Welcome to FG.

    Several places; the information is accessible via the reference manuals that you'll find in each module and you can also access the classes directly from the library or from the class list on the right hand side. The archetypes will be split across any modules that you have open; so if you want to read about the Gloom Stalker you'll need to read about it in Xanathar's guide since that's where you'll find it.
    If you need to contact customer support or if there is something that you would like to see in Fantasy Grounds that isn't currently part of the software or if there is something you think would improve a ruleset then add your idea here http://fgapp.idea.informer.com/

  3. #3
    I guess I don't know how to access the modules. I assume you are calling Xan's a module. (Back in my day when I played in the 80's, "modules" were specifically the games or adventures.) I did do a search and read that you can't actually read the manuals like a book but maybe I read faulty info.

    I did try the Library with no luck. I tried it again just now, too. I can see Xan's is loaded in the left window but when I input Gloom Stalker into the search field to the bottom-right, I get nothing. I even try to click Xan's in the left window to see if that helps but it does nothing. I think I'm missing something here.

    I don't have Class as a button on the far right. I did see somewhere how I can add more buttons and have to find that again as that may be the ticket. However, with a 15" monitor on a laptop, I'm pressed for room.

    However, success! Just now. So I will share in case anyone else has trouble. I, again, clicked the name of the Module in the left window and this time a list of things showed up in the right window. Maybe it takes time to load the stuff in? I was clicking it before but I guess searching too quickly before it could load in, maybe. Anyhow, I now see it and see the dragon icon and so can drag it to an easily accessible place. Thanks for the help! The problem was that the right window was not populating or not populating fast enough and I'm impatient...or something. THank you!

  4. #4
    The side buttons also link to various records such as feats, spells, classes, etc. Also, the library window shoes that some modules have a reference manual which is slightly easier to read imo.

  5. #5
    I read that you found what you wanted, here some quick tips anyway. Maybe they can help you. In all cases welcome to the FG forums.

    A module (in FG terms) is a product you purchase in the store. There are also extensions but generally most of the stuff are modules. You can find them in game in your Library window to the bottom left.
    You can also read all the manuals like a book although I'd say it's more of "like a PDF".

    When you see a module that you have loaded in your library you can left click it to take a look at its contents on the right side of the window, it should outline and underline the title if you hover over it as well. In there you should be able to find the 'Reference Manual' which you can open by clicking on the shield icon. Just to clarify; the search bar on the bottom right of the Library is to search through your loaded modules not their contents. So Gloom Stalker wouldn't be able to come up here.

    To change the sidebar, you open up the options menu (gear icon in the to right), where you can find a button called 'Sidebar'. It opens up a new window where you can individually select which sidebar icons you want to have acive. You can click 'All' to just pull up all of them to get a good overview.
    Last edited by Evolivolution; March 5th, 2021 at 21:25.
    Discord: Evolivolution#0281
    Ultimate License (FGU)
    Timezone: GMT+1

  6. #6
    Quote Originally Posted by Evolivolution View Post
    When you see a module that you have loaded in your library you can left click it to take a look at its contents on the right side of the window, it should outline and underline the title if you hover over it as well. In there you should be able to find the 'Reference Manual' which you can open by clicking on the shield icon. Just to clarify; the search bar on the bottom right of the Library is to search through your loaded modules not their contents. So Gloom Stalker wouldn't be able to come up here.
    Thanks for the help to everyone! It seems there is a problem with the search function. I guess I tried to the search term "Ranger" and "Gloom Stalker" and nothing comes up. It was after that I would specifically click Xan's Players (and others) with one of those search terms still in the search field and still nothing would come up in that right window. It seems the search function does not do anything but will block categories from loading into the right window if a term is entered in the search field at very bottom right. As I type this I click PHB and then I see the headings in the right window and if I input Ranger in the search field, nothing comes up. Not a single word comes up from any module--It seems to me the search field is for naught, really. Or is that not a search field? It looks like a magnifying glass.

    It would be great during the character creation that the things like sub-classes were hyperlinked to open to that section. The program detects that I have the book and brings up that option for a sub-class and so clicking on it should bring up that window. This will really help new players I try to get started in this game as they won't have a clue at all as to this program.

    Thanks all! I'm still learning.

  7. #7
    Like I said the search bar in the Library window is just for searching terms in your modules. So you could search for 'player' and it would bring up the players handbook or you could search for 'equipment' and it would bring up all modules that contain equipment and if you clicked on any of them (leaving the equipment in the search bar) you would only see 'Equipment' on the right side.
    If you want to look for anything specific you can open up the 'Reference Manual' section of any module and it has a search bar of its own, where you then can look for 'Ranger' or 'Gloom Stalker' and have the programm find what you are looking for.
    Discord: Evolivolution#0281
    Ultimate License (FGU)
    Timezone: GMT+1

  8. #8
    I appreciate your patience. I don't think I am understanding this search function. When I open Library, in the left window it shows all my modules uploaded. DMG, PHB, MM, Volo's, Xanathar's. The right window is blank. If I input "player" into the search function, nothing happens. Is it supposed to bring up the PHB if I don't have it already uploaded? I tried equipment and it does not bring in my other modules such as The Yawning Portal which surely has equipment listed. Nothing happens in fact, that I see, and nothing appears in the right window. So, the search doesn't seem to bring up any modules or narrow my list to any specific modules. The search field just turns pink and nothing happens. I am failing to see its purpose. I fear I am not understanding something that is very simple, though.

    Yes, opening a specific module and searching within its Reference Manual produces a search result. That works great.

  9. #9
    Sorry, little confusion on my part actually.
    The search bar in the library section is just for the contents of a module (the right side of the library window). So you will always see all of your loaded modules on the right side but if you search for anything and then click on the modules to bring up their contents it will only show you the ones that also match your search term. So if you search for 'equipment' it will only show you the Equipment section of every module if you click on them but all your loaded modules and if the module doesn't contain an Equipment section the right side will just appear empty if you click on it (the module).
    Sorry again, I got a bit mixed up.
    Discord: Evolivolution#0281
    Ultimate License (FGU)
    Timezone: GMT+1

  10. #10
    You are going to tire of me! LOL.

    I see my loaded modules in the left window. Nothing in the right window. I click on MM and now see in the right window: Tables, Images, NPCs, Reference Manual. If I search "Dragon," the field turns pink and the right window clears and shows nothing. If I type "images," it shows the image link. Ok, but I'm not very impressed as I can already see the list of the four headers or sections and don't need to search for any of them such as "images." If I click NPCs I then get a new search field and in THAT field I can now search "Dragons" or what-not. Not much of a time-saver in regards to not having to open a bunch of windows.

    That initial search field is kind of weak and seems to only search for the headings you can already see in the right window. Maybe the plan was that some modules will have a huge extent of subjects/headings (for lack of a better term.)

    Even if I open Xan's, then click Classes, and then enter "gloom stalker," the search field will turn pink and you get no result. (Searching "Ranger" doesn't even work!) You have to go all the way to Xan's, Classes, Ranger and then you get a pop-up window with the explanation of the Ranger and at the bottom you see Gloom Stalker. I can't actually do a meaningful search for the term at all. This seems weird to me and a very impotent function. I'm having difficulty thinking I'm the only one to have trouble here so I think I'm missing something.

    Thank you so much for your patience!

    search01.png
    search02.png

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
5E Storm Kings Thunder Playlist

Log in

Log in