Joshua Stream Pre
Page 2 of 3 First 123 Last
  1. #11
    smelton's Avatar
    Join Date
    Jul 2016
    Location
    Plano, TX
    Posts
    257
    Was FGU running before the last update?

  2. #12
    smelton,
    Yes, it was running before the last update, and I think after the last app update, too - this hit me when I ran the updater the day I've started the thread.

    I've been trying different things, and I think this is a local permissions issue, and not an FG app issue - I just haven't figured out the full resolution.

    What I discovered is:

    1. a different user logged in under different FG account (i.e. 2nd demo account that I use as a client when I'm running a game on my main iMac) could launch FGU and everything behaved as normal, even after all of the various updates I ran (including forced updates).

    2. I built a new user (non-admin) but had some odd problems - FGU would launch, but the FantasyGroundsUpdater.app wouldn't (no window appeared). FGUpdaterEngine.app launched, but I couldn't finish setting up a user, because I couldn't change permissions needed with this user.

    3. I converted the user to an admin user, and had the same issues, with the message "Fantasy Grounds Updated does not have write acces to either the Application or Data directory."

    4. I ran FGUpdaterEngine.app via sudo and was able to enter my regular user and Ultimate license info. At this point I can launch FantasyGrounds.app, or FGUpdaterEngine.app (but get the error in #3 but can continue to the Updater), but FantasyGroundsUpdater.app still won't launch.


    At this point, I am wondering if installing under my regular admin user has mangled permissions, but I am not sure why, since I didn't do anything nonstandard with the install. As this isn't a critical computer (primarily 2nd user and testing) I would like to wipe everything fantasy grounds and then am thinking of re-installing from a freshly created admin user that has no history.

    My new question is, other than the App and Data folder, plus Library/Preferences/Smiteworks folders, is there any other location I need to delete?

    Alternatively, is there anything in this narrative that suggests something specific that I should fix, or any logs you might be interested in seeing?

    Thanks
    G

  3. #13
    UPDATE
    I deleted the Smiteworks folder in Applications, the Smitework user folders, and the Smiteworks preferences folder, then installed from a newly created admin-level account.

    After the install, the new admin user, and other (non-primary) users can launch FGU.
    My primary user (also admin-level) still won't launch FantasyGrounds.app (crash before screens appear), but if I launch FantasyGrounds.app via sudo (and the extended path inside the package), FGU will launch as expected.

    This definitely is a permissions issue. I have no idea where, unfortunately. Initially, when I ran the FantasyGroundsUpdater, I had a "permissions" error window in the updater, for which the fix options wouldn't work, but when I ran this as admin (via SUDO), that stopped happening.

    -G

  4. #14
    Thanks for letting us know. I've forwarded to @smelton, so that he can see what you've done.

    Regards,
    JPG

  5. #15
    smelton's Avatar
    Join Date
    Jul 2016
    Location
    Plano, TX
    Posts
    257
    Quote Originally Posted by fieldson View Post
    UPDATE
    I deleted the Smiteworks folder in Applications, the Smitework user folders, and the Smiteworks preferences folder, then installed from a newly created admin-level account.

    After the install, the new admin user, and other (non-primary) users can launch FGU.
    My primary user (also admin-level) still won't launch FantasyGrounds.app (crash before screens appear), but if I launch FantasyGrounds.app via sudo (and the extended path inside the package), FGU will launch as expected.

    This definitely is a permissions issue. I have no idea where, unfortunately. Initially, when I ran the FantasyGroundsUpdater, I had a "permissions" error window in the updater, for which the fix options wouldn't work, but when I ran this as admin (via SUDO), that stopped happening.

    -G
    Ping me on Discord (smelton#0068) and I'll help you troubleshoot

  6. #16
    I was wondering if you have been able to find a fix for this as I seem to be experiencing a similar permission issue. I'm running version is v4.1.2 on macOS Big Sur. I'm able to launch the updater without issue, but Fantasy Grounds.app fails to load. I have tried multiple reinstalls but with no success. Running the app via terminal with sudo works but I'm hoping for a solution that doesn't require this work around.

  7. #17
    I haven't solved the problem - I have been focused on other parts of life since February and haven't followed up with @smelton.
    This isn't my primary computer so I put up with it.

  8. #18
    smelton's Avatar
    Join Date
    Jul 2016
    Location
    Plano, TX
    Posts
    257
    Quote Originally Posted by Chilipig View Post
    I was wondering if you have been able to find a fix for this as I seem to be experiencing a similar permission issue. I'm running version is v4.1.2 on macOS Big Sur. I'm able to launch the updater without issue, but Fantasy Grounds.app fails to load. I have tried multiple reinstalls but with no success. Running the app via terminal with sudo works but I'm hoping for a solution that doesn't require this work around.
    I'm running Big Sur as well and haven't been able to replicate this issue so my initial thought is it is something specific to your setup. If you want to ping me on Discord I can try to help you troubleshoot the issue further.

  9. #19
    I get this problem reliably since around february on Big Sur on an M1 mac Mini so its a Rosetta issue. When the OS updates the problem disappeared. Then a few days later its back again. I have reinstalled it and now it works again (didn't bother uninstalling first). I am expecting it to fail again in a few days - let's see.

  10. #20
    I'm consistently getting this on an M1 Macbook Air with Big Sur. Just did an uninstall and reinstall, no luck. It did run without issue previously. I'm exploring whether Malwarebytes is blocking it, but I've had that installed since day one so I doubt it.


    Process: Fantasy Grounds [19536]
    Path: /Applications/SmiteWorks/*/FantasyGrounds.app/Contents/MacOS/Fantasy Grounds
    Identifier: unity.SmiteWorks.Fantasy Grounds
    Version: ???
    Code Type: X86-64 (Translated)
    Parent Process: ??? [1]
    Responsible: Fantasy Grounds [19536]
    User ID: 501

    Date/Time: 2021-07-28 10:17:06.890 -0400
    OS Version: macOS 11.4 (20F71)
    Report Version: 12
    Anonymous UUID: 2C8AF6FF-DF70-87F3-BF98-3B007AA0CBE1

    Sleep/Wake UUID: 2930705D-68D4-4710-B257-7085EDDA8360

    Time Awake Since Boot: 70000 seconds
    Time Since Wake: 4100 seconds

    System Integrity Protection: enabled

    Crashed Thread: 0

    Exception Type: EXC_BREAKPOINT (SIGTRAP)
    Exception Codes: EXC_ARM_BREAKPOINT at 0x00007ffdffed8370 (brk 1)
    Exception Note: EXC_CORPSE_NOTIFY

    Termination Signal: Trace/BPT trap: 5
    Termination Reason: Namespace SIGNAL, Code 0x5
    Terminating Process: exc handler [19536]

    Application Specific Information:
    rosetta error: /var/db/oah/c642c66595f5050af26db8f86497ea83caff7cea5a9bcb2361 ffa81d0e090b58/923c6b322f5f707c20d8e959f0edaeac4ee71fdc0812dd8006 327f4bb62a3daf/Fantasy Grounds.aot: attachment of code signature supplement failed: 3


    Thread 0 Crashed:
    0 runtime 0x00007ffdffed8370 0x7ffdffe85000 + 340848
    1 runtime 0x00007ffdffed83bc 0x7ffdffe85000 + 340924
    2 runtime 0x00007ffdffe92fe4 0x7ffdffe85000 + 57316
    3 runtime 0x00007ffdffe9452c 0x7ffdffe85000 + 62764
    4 runtime 0x00007ffdffe94024 0x7ffdffe85000 + 61476
    5 runtime 0x00007ffdffe86280 0x7ffdffe85000 + 4736
    6 ??? 0x0000000000000003 0 + 3

    Thread 0 crashed with ARM Thread State (64-bit):
    x0: 0x0000000000000000 x1: 0x0000000000000003 x2: 0x000000000000003c x3: 0x000000000000002c
    x4: 0x0000000000000303 x5: 0x0000000000000000 x6: 0x0000000000000000 x7: 0x000000000000236b
    x8: 0x00007ffdfff05000 x9: 0x0000000000000000 x10: 0x00007ffdffefbc5d x11: 0x0000000000000000
    x12: 0x00007ffdffeef6a0 x13: 0x00007ffdffeef690 x14: 0x00007ffdffeeaa30 x15: 0x0000000000000020
    x16: 0xffffffffffffffe1 x17: 0x00007ffdffedc7f4 x18: 0x0000000305fdca43 x19: 0x00007ffdffefbb78
    x20: 0x0000000305fdd0f8 x21: 0x0000000100dab000 x22: 0x0000000000000103 x23: 0x0000000100dab000
    x24: 0x0000000000000003 x25: 0x0000000000000001 x26: 0x0000000305fdc550 x27: 0x00007ffdffe85000
    x28: 0x0000000000000001 fp: 0x0000000305fdb2f0 lr: 0x2b13fffdffed8368
    sp: 0x0000000305fdb2d0 pc: 0x00007ffdffed8370 cpsr: 0x60000000
    far: 0x00007ffdfff06000 esr: 0xf2000001


    Binary Images:
    0x20112a000 - 0x2011c5fff dyld (852) <1AC76561-4F9A-34B1-BA7C-4516CACEAED7> /usr/lib/dyld
    0x7ffdffe85000 - 0x7ffdffef8fff +runtime (203.46) <C447D2A9-BB07-30A8-97AB-399362D14FC8> /Library/Apple/*/runtime

    External Modification Summary:
    Calls made by other processes targeting this process:
    task_for_pid: 0
    thread_create: 0
    thread_set_state: 0
    Calls made by this process:
    task_for_pid: 0
    thread_create: 0
    thread_set_state: 0
    Calls made by all processes on this machine:
    task_for_pid: 0
    thread_create: 0
    thread_set_state: 0

    VM Region Summary:
    ReadOnly portion of Libraries: Total=1324K resident=0K(0%) swapped_out_or_unallocated=1324K(100%)
    Writable regions: Total=18.8M written=0K(0%) resident=0K(0%) swapped_out=0K(0%) unallocated=18.8M(100%)

    VIRTUAL REGION
    REGION TYPE SIZE COUNT (non-coalesced)
    =========== ======= =======
    STACK GUARD 56.0M 1
    Stack 8176K 1
    VM_ALLOCATE 10.5M 1
    VM_ALLOCATE (reserved) 32K 1 reserved VM address space (unallocated)
    __DATA 288K 4
    __DATA_CONST 32K 1
    __LINKEDIT 272K 4
    __TEXT 1088K 2
    mapped file 4.7G 9
    =========== ======= =======
    TOTAL 4.8G 24
    TOTAL, minus reserved VM space 4.8G 24

    Model: MacBookAir10,1, BootROM 6723.120.36, proc 8:4:4 processors, 8 GB, SMC
    Graphics: kHW_AppleM1Item, Apple M1, spdisplays_builtin
    Memory Module: LPDDR4
    AirPort: spairport_wireless_card_type_airport_extreme, wl0: Apr 28 2021 19:53:33 version 18.50.40.7.7.8.119 FWID 01-e6894c69
    Bluetooth: Version 8.0.5d7, 3 services, 27 devices, 1 incoming serial ports
    Network Service: Wi-Fi, AirPort, en0
    USB Device: USB 3.1 Bus
    USB Device: USB 3.1 Bus
    Thunderbolt Bus: MacBook Air, Apple Inc.
    Thunderbolt Bus: MacBook Air, Apple Inc.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
DMsGuild Classic

Log in

Log in