PF2E Playlist
Page 3 of 8 First 12345 ... Last
  1. #21
    Just pushed update for 5E to fix the death saving throw roll result function. Let me know if you still see an issue after update.

    Regards,
    JPG

  2. #22
    Quote Originally Posted by Moon Wizard View Post
    Just pushed update for 5E to fix the death saving throw roll result function. Let me know if you still see an issue after update.

    Regards,
    JPG
    Thanks Ill check that later tonight.

    The combo box bold highlights current selection in the drop down box - If your saying it did not do it without first rechoosing it after startup Ill have to check again later. But pretty sure it did and I could see the select logic had changed.

  3. #23
    Quote Originally Posted by SilentRuin View Post
    Thanks I’ll check that later tonight.

    The combo box bold highlights current selection in the drop down box - If your saying it did not do it without first rechoosing it after startup I’ll have to check again later. But pretty sure it did and I could see the select logic had changed.
    @Moon Wizard,
    I don't know what just got updated with death indicators but now death rolls get checked - but the extension now goes into instant death (tombstone) any time they reach 0 hit points (it did not do that till this most recent update). Can you tell me what you just changed for that? Something is now broken in extension which keeps track of when your at 0 hp but still have saving throws.

    As far as the combobox I was correct - something got broken in the change. The thing is the underlying engine code for the lists or something will bold any active entry when you pull down the drop box. It still does that AFTER you choose one. But the one that is already there in the DB list is no longer showing bolded when you come up like it used to (when you first come up). As I said - I saw where you changed how all that select is handled and did not feel like trying to figure out the new stuff and what was missing as you know what its doing. If I had to guess, you removed the initial set of the select index on startup of the list. But I really don't know.

    Here is proof in two screen shots - one where I use the raw combobox (straight out of CoreRPG common) on LIVE - then on TEST. It's doing what I said - and not working any more in TEST unless you choose one.
    Attached Images Attached Images
    Last edited by SilentRuin; February 8th, 2021 at 05:43.

  4. #24
    Quote Originally Posted by Moon Wizard View Post
    Just pushed update for 5E to fix the death saving throw roll result function. Let me know if you still see an issue after update.

    Regards,
    JPG
    Never mind I'm an idiot confused to which campaign I was in. The death save stuff works fine now.

    All that is left that I know of is the initialization of combobox not setting the active select index so it is bolded first time drop down comes up. I can see the logic changed, and that normal clicked processing sets that select index - so once selected it works correctly. But really want that original behavior back where it shows selected (bolded) when it first comes up.

  5. #25
    [ERROR] Script execution error: [string "scripts/manager_actor.lua"]:71: attempt to call field 'getPath' (a nil value)

    Trying to figure out how I got this. It appears its one of the many resolveActor calls I had to replace getActor with. Looking at the code, the old getActor used to call getnodename and this new resolveActor calls getpath - not sure why it would fail here or how. I'll try and add a bunch of prints to see if I can figure out if it was some bug on my side that just used to get away with it - but any hints on what is going on would be useful.

    [Note: error occurred on client(player) side of the code only - worked from host]
    Last edited by SilentRuin; February 8th, 2021 at 15:53.

  6. #26
    Quote Originally Posted by SilentRuin View Post
    [ERROR] Script execution error: [string "scripts/manager_actor.lua"]:71: attempt to call field 'getPath' (a nil value)

    Trying to figure out how I got this. It appears its one of the many resolveActor calls I had to replace getActor with. Looking at the code, the old getActor used to call getnodename and this new resolveActor calls getpath - not sure why it would fail here or how. I'll try and add a bunch of prints to see if I can figure out if it was some bug on my side that just used to get away with it - but any hints on what is going on would be useful.

    [Note: error occurred on client(player) side of the code only - worked from host]
    This happens with no extensions. And since I can't seem to figure out how to package up my own version of CoreRPG.pak ruleset with prints in the resolveActor code right before line 71 (the call for nodeActor.getPath()) I can't really tell why/what is going on. All I can say its easy for me to duplicate. I have one PC with 1 HP left before 0 - then I target and do damage on him with a client(player). BOOM. This error. Every time. I'm guessing that the player side does not have access to something and the new resolveActor code is not taking that into account somehow.

  7. #27
    I'm not seeing this. I just tried applying damage to a PC with 1 hp in a 5E campaign; and I did not get any errors.

    Can you give me the exact steps?

    Thanks,
    JPG

  8. #28
    Kelrugem's Avatar
    Join Date
    Sep 2018
    Location
    Geneva, Switzerland, and Lyon, France
    Posts
    2,947
    Quote Originally Posted by Moon Wizard View Post
    I'm not seeing this. I just tried applying damage to a PC with 1 hp in a 5E campaign; and I did not get any errors.

    Can you give me the exact steps?

    Thanks,
    JPG
    I was able to reproduce:

    1. Create a 5e campaign
    2. Create two PCs
    3. Drag them to the CT and give one of them 1 HP
    4. Join yourself and take control over the other PC (not the 1 HP one)
    5. Roll a damage die as client against the 1 HP PC (I dragged the damage die to the CT entry of the 1 HP PC, in case that matters)


  9. #29
    I'm not seeing that locally. I just pushed new builds of CoreRPG and 5E rulesets; just in case something was out of synch. Can you guys try again?

    Thanks,
    JPG

  10. #30
    @SilentRuin
    I think I also found the combo box bolding you were talking about, and hooked it up again. It should be in the new builds too.

    Regards,
    JPG

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Joshua Stream Pre

Log in

Log in