FGCon2021
Page 2 of 8 First 1234 ... Last
  1. #11
    Quote Originally Posted by Moon Wizard View Post
    If you don't want to use the existing template, you can rename yours to something else to be used for your specific combo box scenarios. I wouldn't override the default; since that is used for languages and speakers in the chat window.

    Regards,
    JPG
    I know that - that is what I did - unfortunately now the current combobox (which I used before in something else) no longer bolds the text in the drop down that is currently highlighted. And my overloaded version no longer "makes room" by expanding and contracting subwindows (done in mycombbox.lua). I don't know why or what changed. One is your new one (no bold now) and one is my old one (logic added in to make room for a new subwindow then remove that room when no longer needed). I don't know what has changed because too many renaming of things happened.

  2. #12
    Quote Originally Posted by Moon Wizard View Post
    If you don't want to use the existing template, you can rename yours to something else to be used for your specific combo box scenarios. I wouldn't override the default; since that is used for languages and speakers in the chat window.

    Regards,
    JPG
    Oh and in mine the drop down text is invisible.

  3. #13
    I'm going to guess that since I only replaced <template name="combobox"> in my version with the .lua file also that something else in the template has changed - which I can see has with some anchor points added in - which may destroy my anchor logic resizing the subwindow. I'm not sure how or why that would make all my lists go invisible but it's a place to start I suppose. Maybe tomorrow as its late.

  4. #14
    There are some issues with the characterlist.

    I am using FGC, dev-Channel, updated CoreRPG today.

    1. While using the radial menu to reset position, the button is not working. Error Message: "Script Error: [string "desktop/scripts/characterlist.lua"]:44: attempt to call global 'resetPosition' (a nil value)"

    2. The offset in anchoring of left und top is not working properly when launching die campain first time. A reset via radial menu is working. But first draw in a new campaign is allway offset="0".

    May be there is something wrong with getting data from windowstate.xml when there is no entry for characterlist using default 0 for offset instead of using the offset specified in the template.

    Here the code I tested:

    Code:
    <panel name="characterlist">
    	anchored height="85" width="40">
    		<left offset="100" />
    		<top offset="50" />
    	</anchored>
    	<class>characterlist</class>
    	<dynamic />
    	<locked />
    </panel>

  5. #15
    My changes are not that big a deal so I basically moved them into your new combobox (still has bug where drop down no longer bolds the current selection). Whatever your doing though seems to have changed the behavior in subwindows - or something in general has changed. I do not want my subwindows scrolling because the combobox does not fit in them - I want them to overlay the subwindow below it - which I have changed size of to compensate for it while it's being clicked. Only now - none of that logic works anymore. If I stick with my original version it works fine in the drop down not forcing the scroll - but the drop down text is invisible for some reason in TEST version. Not in LIVE version. And when I insert these subwindows at the top of the tabs in all my PC/NPC sheets they are simply missing. Not there in the TEST version.

    So I guess I'll try to look into the key problems I have right now:

    1) Why is my old mycombobox (copy of old combobox with my minor additions) not showing any text but working in all other respects - has some kind of font/color changed internally?
    2) Why the new combobox forces scrolling in subwindows even with my logic added in.
    3) Why the new combobox does not bold the current selected text.
    4) Why my window logic in tabs is no longer working (ex. window.parentcontrol.window.skills.setAnchor("top" , "name", "bottom", "relative", 128)).

    Those are the main issues I've found so far. Any help to shortcut the amount of debug prints I'm going to have to add in would be appreciated.

  6. #16
    Quote Originally Posted by SilentRuin View Post
    My changes are not that big a deal so I basically moved them into your new combobox (still has bug where drop down no longer bolds the current selection). Whatever your doing though seems to have changed the behavior in subwindows - or something in general has changed. I do not want my subwindows scrolling because the combobox does not fit in them - I want them to overlay the subwindow below it - which I have changed size of to compensate for it while it's being clicked. Only now - none of that logic works anymore. If I stick with my original version it works fine in the drop down not forcing the scroll - but the drop down text is invisible for some reason in TEST version. Not in LIVE version. And when I insert these subwindows at the top of the tabs in all my PC/NPC sheets they are simply missing. Not there in the TEST version.

    So I guess I'll try to look into the key problems I have right now:

    1) Why is my old mycombobox (copy of old combobox with my minor additions) not showing any text but working in all other respects - has some kind of font/color changed internally?
    2) Why the new combobox forces scrolling in subwindows even with my logic added in.
    3) Why the new combobox does not bold the current selected text.
    4) Why my window logic in tabs is no longer working (ex. window.parentcontrol.window.skills.setAnchor("top" , "name", "bottom", "relative", 128)).

    Those are the main issues I've found so far. Any help to shortcut the amount of debug prints I'm going to have to add in would be appreciated.
    4) Solved

    It appears I still have <actor>.sType == "pc" and <actor>.sType == "npc" and <actor>.sType == "ct" type of checks in the code - which now no longer work (can be "charsheet" for "pc" where it was not before). I will have to bite the bullet and replace all the ActorManager.getType* type of logic or at least validate it (sigh)

  7. #17
    Quote Originally Posted by SilentRuin View Post
    4) Solved

    It appears I still have <actor>.sType == "pc" and <actor>.sType == "npc" and <actor>.sType == "ct" type of checks in the code - which now no longer work (can be "charsheet" for "pc" where it was not before). I will have to bite the bullet and replace all the ActorManager.getType* type of logic or at least validate it (sigh)
    1) Solved

    Was due to choking on missing actor upgrades/rewrites no longer working the same way.

    2) Solved

    Was due to choking on missing actor upgrades/rewrites no longer working the same way.

    3) Still bugged

    The combobox does not initialize the selected active list entry when it first comes up. It used to do this. This causes the drop down not to bold the currently selected value until you actually select it again. First time it is up it will not show as bolded.
    Also when I put my old changes into the new combobox for mycombobox everything seemed to work except when I select from the dropdown box. Then I get the following error:

    [ERROR] Script execution error: [string "common/scripts/mycombobox.lua"]:214: attempt to index field '?' (a nil value)

    The line (same as in new combobox) is

    Code:
    function refreshValueDisplay()
    	if _nSelection > 0 then
    		setValue(_tItems[_tOrderedItems[_nSelection]].text);
    		setTooltipText(_tItems[_tOrderedItems[_nSelection]].text)               <============    Line 214
    	else
    		setValue("");
    		setTooltipText("");
    	end
    
    	if _ctrlList then
    		_ctrlList.setSelection(_nSelection);
    	end
    end
    Took a long time to rewrite all those actor things so now I'll see what this new tooltip is and why its complaining. I'm assuming there is some new "thing" that a mere replacement of the "combobox" template and it's .lua code is missing. I assume the fix to get the initial selection fixed is self explanatory (as I'm not going to look up where that is unless I have to).

    Still not done testing as all those changes are just begging for a typo/cut paste error by the sheer number of them alone.

  8. #18
    Quote Originally Posted by SilentRuin View Post
    1) Solved

    Was due to choking on missing actor upgrades/rewrites no longer working the same way.

    2) Solved

    Was due to choking on missing actor upgrades/rewrites no longer working the same way.

    3) Still bugged

    The combobox does not initialize the selected active list entry when it first comes up. It used to do this. This causes the drop down not to bold the currently selected value until you actually select it again. First time it is up it will not show as bolded.
    Also when I put my old changes into the new combobox for mycombobox everything seemed to work except when I select from the dropdown box. Then I get the following error:

    [ERROR] Script execution error: [string "common/scripts/mycombobox.lua"]:214: attempt to index field '?' (a nil value)

    The line (same as in new combobox) is

    Code:
    function refreshValueDisplay()
    	if _nSelection > 0 then
    		setValue(_tItems[_tOrderedItems[_nSelection]].text);
    		setTooltipText(_tItems[_tOrderedItems[_nSelection]].text)               <============    Line 214
    	else
    		setValue("");
    		setTooltipText("");
    	end
    
    	if _ctrlList then
    		_ctrlList.setSelection(_nSelection);
    	end
    end
    Took a long time to rewrite all those actor things so now I'll see what this new tooltip is and why its complaining. I'm assuming there is some new "thing" that a mere replacement of the "combobox" template and it's .lua code is missing. I assume the fix to get the initial selection fixed is self explanatory (as I'm not going to look up where that is unless I have to).

    Still not done testing as all those changes are just begging for a typo/cut paste error by the sheer number of them alone.
    3) Partially solved for mycombbox - combbox still not bolding (and neither is my copy) on initialization. I looked at that for a bit but it was to confusing on where the set select at init should be done. I'd rather wait till combobox is fixed then fix my copy.

    Fixed mycombobox by commenting out the tooltips. People do add tooltips to the combobox they create with the template - when they do - like me - this code blows them out of the water. Not sure if that was the reason or what was causing it. Maybe even guarding it against a nil value would have worked - but I printed out the whole argument and it was the same valid selected text as in setValue. Mystery. Not sure why but this fixed it for me.

    Code:
    function refreshValueDisplay()
    	if _nSelection > 0 then
    		setValue(_tItems[_tOrderedItems[_nSelection]].text);
    --		setTooltipText(_tItems[_tOrderedItems[_nSelection]].text)
    	else
    		setValue("");
    --		setTooltipText("");
    	end
    
    	if _ctrlList then
    		_ctrlList.setSelection(_nSelection);
    	end
    end
    Last edited by SilentRuin; February 7th, 2021 at 21:04.

  9. #19
    Spent time trying to figure out why death saving throws were not working in my extension - only to bring up another 5E no extension campaign in TEST and find that the regular death saving throws don't work either.

    Roll the dice in Main PC tab for death saving throws at bottom and depending on the result the check box should be checked. It never is. Which results in infinite death saving throws. I was testing Death Indicators by having two 0HP players cycling turns till I could see their tombstones appear... it took a long while before I realized something was wrong and checked their main page character sheets to see how many death saving throw check marks on success or failure were marked - zilch.

  10. #20
    @lule,
    Thanks for finding that issue with the resetPosition. There was an internal hookup missing in FGC; I'll push a hot fix on Tuesday.
    If you move the window from the default position, then it will be in that position on the next load. You can reset via the right click menu for now, until the reset button is fixed. It will reset to whatever is defined for the ruleset/extensions you are currently using.

    @SilentRuin,
    There was quite a lot of text above; so not sure where you ended up. I'll look into the death saving throw, since I can recreate that. For the combobox, I don't think that the default template ever bolded the selection, so maybe that was something you did with your custom templates.

    Regards,
    JPG

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
DMsGuild

Log in

Log in