5E Product Walkthrough Playlist
  1. #1
    Sulimo's Avatar
    Join Date
    Dec 2014
    Location
    Pacific Time Zone
    Posts
    301

    Reference Manual and Image Links

    I've looked all over for an explanation of Reference Manuals and Image Links (where you can click the image in the reference manual and have it pop out the image), but I cannot seem to find anything on how it works.

    This is for the RMC ruleset, but I do not think the issue I am experiencing is specific to the ruleset itself.


    A working example of XML and a screen shot showing it working (this is from the Character Law reference manual):
    Code:
    <id-00002>
        <align type="string">center</align>
        <size type="string">400,395</size>
        <image type="image">
            <bitmap type="string">hidden_images\Intro_image_h780.jpg</bitmap>
        </image>
        <caption type="string" />
        <imagelink type="windowreference">
            <class>imagewindow</class>
            <recordname>hiddenimage.id-00006</recordname>
        </imagelink>
        <text type="formattedtext"/>
        <blocktype type="string">image</blocktype>
    </id-00002>
    Then there is a section on for the image itself (in the hidden_images section):
    Code:
    <id-00006>
        <image type="image">
            <bitmap>hidden_images/Intro_image_h780.jpg</bitmap>
        </image>
        <name type="string">Introduction</name>
    </id-00006>




    Here is my attempt to try this in my module, it does not seem to work though:
    Code:
    <id-00001>
        <align type="string">center</align>
        <size type="string">525,700</size>
        <image type="image">
            <bitmap type="string">hidden_images\Creatures_of_Middle_Earth_Image.jpg</bitmap>
        </image>
        <caption type="string"/>
        <imagelink type="windowreference">
            <class>imagewindow</class>
            <recordname>hiddenimage.id-00003</recordname>
        </imagelink>
        <text type="formattedtext"/>
        <blocktype type="string">image</blocktype>
    </id-00001>
    Code:
    <id-00003>
        <image type="image">
            <bitmap>hidden_images/Creatures_of_Middle_Earth_Image.jpg</bitmap>
        </image>
        <name type="string">Front Page</name>
    </id-00003>
    Here it is not working.



    The Image works fine in the Reference Manual itself (you can see it just behind the pop out window), the image in the pop out is blank though. It seems like it cannot find the image for some reason (showing <<New Drawing>>).

    Anyone have any ideas as to what I am doing wrong?
    Not all who wander are lost.

  2. #2
    Mgrancey's Avatar
    Join Date
    Sep 2011
    Location
    Pittsburgh, PA area
    Posts
    949
    In the bitmap tag in last code example, you have the slash swapped. between hidden_images and creatures
    Location: Central Pa (East -5)
    Ultimate License Holder
    Current Campaign: Necessary Evil
    Current Project: Dawn of Daikaiju: Converting, Deadlands: Reloaded The last Sons - Quality Assurance Checking
    Discord: Mgrancey#4994
    "Mad Science" means never stopping to ask "what's the worst thing that could happen?" -- Maxim 14 of The Seventy Maxims of Maximally Effective Mercenaries
    Adventure: Keep Living Life Like There's No Tomorrow and You'll Eventually Be Right,

  3. #3
    Sulimo's Avatar
    Join Date
    Dec 2014
    Location
    Pacific Time Zone
    Posts
    301
    I tried changing the slash, but it did not make any difference.


    I did finally figure it out.

    Basically I had put the <hiddenimage> node under <reference> instead of under <root>

    Once I moved the <hiddenimage> section out of <reference> it worked.
    Not all who wander are lost.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
SWADE Playlist

Log in

Log in