FG Spreadshirt Swag
Page 9 of 11 First ... 7891011 Last
  1. #81
    I always forget that, when it comes to Health, the boxes should be FILLED and then as you take damage, the boxes are EMPTIED. Probably because they are empty by default. Would it make more sense, on character creation, to have the health boxes filled as opposed to empty?

    If I'm the only one that sees this as an issue, no big deal, I just need to remember to fill those boxes up!

  2. #82
    Quote Originally Posted by Valyar View Post
    This is fixed now, it is pushed and will arrive next week I think.
    Thanks Valyar!

  3. #83
    reporting a bug : in vehicles, if I click the service skiff in alien - expansion of space, the console say :
    [6/26/2021 8:30:04 PM] [ERROR] windowcontrol: Database type mismatch on path (armaments) in control (armaments) in class (vehicle_main)
    [6/26/2021 8:30:04 PM] [ERROR] Script execution error: [string "vehicle_main"]:14: attempt to index global 'armaments' (a nil value)

  4. #84
    My players receive the following errors whenever they click on the Crew tab on the PC Ship Sheet. It doesn't happen when they use the Ship tab on the Character Sheet. No extensions loaded. No modules loaded.

    [6/30/2021 11:55:07 AM] [ERROR] Script execution error: [string "campaign/scripts/charship_gunner.lua"]:15: attempt to index local 'charNode' (a nil value)
    [6/30/2021 11:55:07 AM] [ERROR] Script execution error: [string "campaign/scripts/charship_crewmember.lua"]:41: attempt to index local 'playerNode' (a nil value)
    [6/30/2021 11:55:07 AM] [ERROR] Script execution error: [string "campaign/scripts/charship_crewmember.lua"]:41: attempt to index local 'playerNode' (a nil value)
    [6/30/2021 11:55:07 AM] [WARNING] window: Anchored static height ignored for control (portrait) in windowclass (charship_gunner)
    [6/30/2021 11:55:57 AM] [WARNING] template: Could not find template () in class (charship_main)
    [6/30/2021 11:55:57 AM] [WARNING] template: Could not find template () in class (charship_main)
    [6/30/2021 11:55:57 AM] [WARNING] template: Could not find template () in class (charship_main)
    [6/30/2021 11:55:57 AM] [WARNING] template: Could not find template () in class (charship_main)
    [6/30/2021 11:55:57 AM] [WARNING] template: Could not find template () in class (charship_main)
    [6/30/2021 11:55:57 AM] [WARNING] template: Could not find template () in class (charship_main)
    [6/30/2021 11:55:57 AM] [WARNING] template: Could not find template () in class (charship_main)
    [6/30/2021 11:56:00 AM] [ERROR] Script execution error: [string "campaign/scripts/charship_crew.lua"]:5: attempt to index local 'roleNode' (a nil value)
    [6/30/2021 11:57:22 AM] Campaign saved.

  5. #85
    Will look at that tonight.
    The past is a rudder to guide us, not an anchor to hold us back.

  6. #86
    Thanks Valyar. It works fine using the flow system described in the ruleset wiki (players using ship tab on character sheet), so it's not gamebreaking. It's just annoying for them if they want to look at the crew tab on the PC Ship sheet.

  7. #87
    I checked the LIVE version of the ruleset and when I assign PC to crew position there is no error whatsoever, except the warning which is not an issue.
    Can you tell me what are the steps you do in order to reproduce the issue?

    Would you please try also to delete the ruleset and modules from the vault (IPFGALIENRPGFLFALE002.dat) and download it again.
    The past is a rudder to guide us, not an anchor to hold us back.

  8. #88
    As GM, I get no errors at all. I assign the characters to the crew slots on the Crew tab. The error occurs on the player side when they open up the crew tab on the PC Ship sheet.

  9. #89
    Quote Originally Posted by gbhenderson View Post
    As GM, I get no errors at all. I assign the characters to the crew slots on the Crew tab. The error occurs on the player side when they open up the crew tab on the PC Ship sheet.
    OK, found the root cause - the ship sheet isn't shared In our scripts, the ship's name appear in the SHIP ASSIGNMENT field and if you haven't shared the ship with the players, we can't assign name and connect ship-related skill rolls with the modifiers from ship's profile. Once you share the ship, they will have read-only view of it and the tab on PC's sheet works without problem.

    At the moment, our concept is that GM manages the ship's sheet and they are shared explicitly when needed. I will update the ruleset manual to make this clear. Apologies for the inconvenience!
    The past is a rudder to guide us, not an anchor to hold us back.

  10. #90
    Quote Originally Posted by Valyar View Post
    OK, found the root cause - the ship sheet isn't shared
    I think that's the problem. When they first built the ship, I just shared a blank PC Ship sheet with them and let them add their modules, upgrades, etc. That all happened long before all the 2.0 ship combat additions. I'll try rebuilding their ship as GM and see if that fixes it.

    At the moment, our concept is that GM manages the ship's sheet and they are shared explicitly when needed.
    I'd mentioned to them that the ruleset says that the GM runs the ship sheet in combat when needed, and they use the Ship tabs on the PC sheet. I just assumed it was to avoid this happening.
    I'm pretty sure the PC sheet tab was working just fine when we were trying out the new stuff the other night. It was only the Crew tab on the Ship sheet gave them the errors.

    Thanks for looking into it Valyar. I'll build a new ship tomorrow and let you know how it went.



    On a hunch, I just tried going in and unsharing and then resharing the ship. That seemed to fix all the issues.
    Last edited by gbhenderson; July 1st, 2021 at 04:44.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
FG Forge

Log in

Log in