Fantasy Grounds Fridays Pre
  1. #1
    Kelrugem's Avatar
    Join Date
    Sep 2018
    Location
    Geneva, Switzerland, and Lyon, France
    Posts
    3,069

    [BUG] REGEN, FHEAL etc. are causing effect removal error when used with fixed mod

    Hi

    I found the following problem: When someone has the stable effect and some regeneration effect (here: FHEAL: 1), then the following error occurs at the beginning of the turn when the actor goes from -1 to 0 HP:

    Code:
    Script Error: [string "scripts/manager_effect.lua"]:185: attempt to index local 'nodeEffect' (a userdata value)
    Sometimes it does not occur. When the regeneration/fheal effect uses a (EDIT: physical) die, then this error does not occur It looks like that a fixed number effect is "too quick" such that the node of the stable effect cannot be found for its removal (the chat message uses then the GM icon instead of the PC icon for example etc.; hence, my assumption, but I may be wrong)

    Best,

    Kelrugem

    PS: Superteddy is already aware of a similar problem, but for completeness: When one uses the next round button while the actor has a heal effect and is not stabilized, then both can happen: A heal and a damage because of a failed stabilization roll That is probably due to that the next round button triggers everything while the next actor button probably does not reproduce that (heal stuff is at the beginning of the turn, stabilization at the end)

    EDIT: Without extensions of course
    Last edited by Kelrugem; December 10th, 2020 at 03:56.

  2. #2
    So basically I could get it to work with "FHEAL: 1d1"? XD

  3. #3
    Kelrugem's Avatar
    Join Date
    Sep 2018
    Location
    Geneva, Switzerland, and Lyon, France
    Posts
    3,069
    Quote Originally Posted by Asgurgolas View Post
    So basically I could get it to work with "FHEAL: 1d1"? XD
    d1 is not supported as a physical die (I should have mentioned that it is about the physical ones)

    But d2-1 works indeed xD

  4. #4
    Kelrugem's Avatar
    Join Date
    Sep 2018
    Location
    Geneva, Switzerland, and Lyon, France
    Posts
    3,069
    Oki, some more information: It seems to be easier to reproduce with next actor than next round button; but I am not sure yet why I cannot always reproduce it. It seems to be also easier to reproduce at the beginning of the session (and "Turn: Stop at round start" is off, I am not sure why but my intuition tells me that this might be influencing it, too? Not sure, but my actor is at the beginning, and once I change that setting it was difficult to reproduce again)

  5. #5
    Kelrugem's Avatar
    Join Date
    Sep 2018
    Location
    Geneva, Switzerland, and Lyon, France
    Posts
    3,069
    Now I tested again, and for a looong time I was not able to reproduce it, then suddenly I was able to reproduce it again. I have sadly no idea about a full list of steps of reproducing it :/ Now also checked in a new campaign, and it sometimes happen, sometimes not. A very strange bug

  6. #6
    My next session is due tomorrow evening and (as experience dictates) there's no better way to display a bug than playing :P

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Joshua Stream Pre

Log in

Log in