Starfinder Playlist
Page 4 of 54 First ... 2345614 ... Last

Thread: Linux Testing

  1. #31
    Installed on 20.04 Kubuntu using QApt.

    No menu item, but turned up in a search of the menu ... no idea why.

    Ran as a my regular user, updated just fine. Dice worked right. For some reason, probably my system, it defaults to Konqueror as my web browser.

    So far all is well.
    Last edited by Kirsa; August 30th, 2020 at 08:01.

  2. #32

    Join Date
    Nov 2016
    Location
    South Mississippi
    Posts
    35
    Thank you, tgm4883, it works just as you said.
    I still don't have fonts on the buttons in the launcher.
    It is much smoother than FGC w/Proton, but I noticed the CPU usage still goes up as you open more windows inside FG.

  3. #33
    Hi,

    I also did my first tests today on an old, but slightly modded Thinkpad T420 running Ubuntu 18.04. During my short trial I found no major issues. However I noticed some minor flaws:

    • FGU appears under "Unnamed" in the "Others" section of the main menu
    • The buttons on the updater window have white corners, which I assume are supposed to be transparent.
    • The font in the updater and FGU's main window seem quite blurry. On the game table it looks fine, though.
    • The dice are always thrown with maximum speed, unlike in FG Classic where the trajectory is based on the mouse cursors speed. They also don't keep their position on the table. Not sure if this is intentional...


    System info:
    Code:
    $ neofetch
                .-/+oossssoo+/-.               [email protected] 
            `:+ssssssssssssssssss+:`           ------------ 
          -+ssssssssssssssssssyyssss+-         OS: Ubuntu 18.04.5 LTS x86_64 
        .ossssssssssssssssssdMMMNysssso.       Host: 4180PH3 ThinkPad T420 
       /ssssssssssshdmmNNmmyNMMMMhssssss/      Kernel: 4.15.0-108-generic 
      +ssssssssshmydMMMMMMMNddddyssssssss+     Uptime: 55 days, 17 hours, 8 mins 
     /sssssssshNMMMyhhyyyyhmNMMMNhssssssss/    Packages: 4096 
    .ssssssssdMMMNhsssssssssshNMMMdssssssss.   Shell: bash 4.4.20 
    +sssshhhyNMMNyssssssssssssyNMMMysssssss+   Resolution: 1920x1080 
    ossyNMMMNyMMhsssssssssssssshmmmhssssssso   DE: Cinnamon 3.6.7 
    ossyNMMMNyMMhsssssssssssssshmmmhssssssso   WM: Mutter (Muffin) 
    +sssshhhyNMMNyssssssssssssyNMMMysssssss+   WM Theme: (Default) 
    .ssssssssdMMMNhsssssssssshNMMMdssssssss.   Theme: Adwaita-dark [GTK2/3] 
     /sssssssshNMMMyhhyyyyhdNMMMNhssssssss/    Icons: Faenza-Dark [GTK2/3] 
      +sssssssssdmydMMMMMMMMddddyssssssss+     Terminal: gnome-terminal 
       /ssssssssssshdmNNNNmyNMMMMhssssss/      CPU: Intel i7-2720QM (8) @ 3.300GHz 
        .ossssssssssssssssssdMMMNysssso.       GPU: NVIDIA Quadro NVS 4200M 
          -+sssssssssssssssssyyyssss+-         Memory: 4640MiB / 15993MiB 
            `:+ssssssssssssssssss+:` 
                .-/+oossssoo+/-.
    Cheers,
    exo
    Attached Images Attached Images
    Last edited by exocore; August 30th, 2020 at 09:41. Reason: found a typo

  4. #34
    Quote Originally Posted by tgm4883 View Post
    I'm not sure how well it works, as I'm currently only a demo user (just started looking at FG and roll20), but here's the AUR package I've made. I've also made it to install in /opt rather than /usr/share. It will also still complain about not being able to write to the app directory but if you hit cancel you can go to the advanced settings and choose a place in your home directory for it (I chose ~/FGU)

    https://aur.archlinux.org/packages/f...undsinstaller/
    I have a Ultimate licence for FGU - I would take the plunge with classic, I reckon there will be discount Unity upgrades for those that missed the kick-start options at various times, but that's a different topic.

    I will try the AUR version this evening.

    The new linux guy (or gal) seems to be on the ball so the user permissions etc should get sorted soon.

    I want to move my players over to FGU but will hold on while they fix then gameplay differences like token lock and such.

  5. #35
    I should have posted this before but I always have my Data folder on a separate drive. So I told the installer to use that drive for the data folder (a copy of my Classic folder) and also made an App folder on the same drive. Works fine.

    LinuxNeo.png
    Last edited by Jiminimonka; August 30th, 2020 at 20:40.

  6. #36
    Had a player on Windows connect to my table (a copy of our FGC table) and she had no issues connecting. And no issues with anything else either. Worked like a dream. Just the Linux side was an issue - mousewheel not working mostly it seems.

  7. #37
    Quote Originally Posted by Jiminimonka View Post
    Had a player on Windows connect to my table (a copy of our FGC table) and she had no issues connecting. And no issues with anything else either. Worked like a dream. Just the Linux side was an issue - mousewheel not working mostly it seems.
    Knowing FGU is written in Unity I've seen this in other Unity apps on Linux as well. If it is the same issue, it looks like it was fixed in a newer version of Unity.

    https://issuetracker.unity3d.com/iss...n-linux-player

  8. #38

    Join Date
    May 2020
    Location
    Queensland, Australia
    Posts
    61
    I downloaded the deb file, pulled it apart and manually installed it on my Gentoo system.

    I fired it up, the updater ran smoothly and I was able to start the sample campaign (I don't have a licence yet - I'm waiting for this linux version to be released/sold).

    It seemed to work fine in my limited playing around. I can also confirm that the mouse wheel scrolling was the reverse of what I was expecting.

  9. #39
    Seems like we are almost there. End of the week I reckon. No pressure!

  10. #40
    So, I've chose the path of madness and went ahead and installed this on an AWS EC2 instance running Ubuntu 18.04.5 LTS, which I access using nomachine for a remote gui. Desktop environment is i3, and this is all working fine and dandy and snappy. FGU installed just fine, but when I try to run it, it flashes a widget and bombs out before it ever draws enough for me to read the text. It sees the update engine, then it tries to find FantasyGroundsUpdate_NEW and chokes and exits 1. The instance clearly has internet access, and even running with elevated (root) permissions the process dies. Strace tells me it's because no supported renderers are found, so I grabbed freeglut3-dev to get an openGL renderer, no joy. Am I going to have a bad time going down this path, or does anyone that does more desktop linux have a bone they could throw me?

    *facepalm* need an instance with a gpu. Will report back when I have some more time to fiddle. - * nope, I can run other openGL apps. Guess I'm trying to live a little too far into the future.
    Last edited by themensch; September 1st, 2020 at 15:17.

Thread Information

Users Browsing this Thread

There are currently 4 users browsing this thread. (0 members and 4 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
DMsGuild

Log in

Log in