SWADE Playlist
Page 69 of 69 First ... 1959676869

Thread: Linux Testing

  1. #681
    The file dialogs do not currently work in the Linux version of FG, so import/export of files will not work. We have a ticket out with the company who makes the file library, but do not have an ETA from them on a fix.

    Regards,
    JPG

  2. #682
    Quote Originally Posted by Moon Wizard View Post
    The file dialogs do not currently work in the Linux version of FG, so import/export of files will not work. We have a ticket out with the company who makes the file library, but do not have an ETA from them on a fix.

    Regards,
    JPG
    damn thats annoying... used to work so wonder what broke. Kinda an important part of the product at times

  3. #683
    You can get them work by wrapping a shell script around the FG application launch. See this post:
    https://www.fantasygrounds.com/forum...l=1#post663408

    The problem is that the only file dialog library built natively as an asset for Unity which also supports Linux uses X11 display server, and Ubuntu and other Linux flavors have recently moved to forcing XWayland. As I mentioned, I've escalated to the Unity asset library developers, but no news from them.

    Regards,
    JPG

  4. #684
    @pord,

    What Linux distribution, desktop environment and display server are you using?

    FGU is specifically built for Ubuntu 2018.04 or newer, which is what the Unity build tool supports. I have a possible library fix; but I can't reproduce the issue locally on the Ubuntu default builds. I need to reproduce to be able to verify that the new library fixes, and doesn't break the default standard Ubuntu builds.

    Thanks,
    JPG
    Last edited by Moon Wizard; December 2nd, 2022 at 22:09.

  5. #685
    Quote Originally Posted by Moon Wizard View Post
    @pord,

    What Linux distribution, desktop environment and display server are you using?

    FGU is specifically built for Ubuntu 2018.04 or newer, which is what the Unity build tool supports. I have a possible library fix; but I can't reproduce the issue locally on the Ubuntu default builds. I need to reproduce to be able to verify that the new library fixes, and doesn't break the default standard Ubuntu builds.

    Thanks,
    JPG
    Using Opensuse tumbleweed with gnome on wayland now.... worked fine with the above fix you posted before. Thanks

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
5E Character Create Playlist

Log in

Log in