Fantasy Grounds Fridays Pre
Page 8 of 9 First ... 6789 Last
  1. #71
    Hi Silentruin,

    Since the recent FGU update, I've been getting a error from your Polymorph Extension

    To reproduce this error:
    1) PC must have the wildhsape class feature added
    2) PC must not be on the Combat Tracker
    3) Press the action tab --> triggers console error

    The error I'm seeing is quite long though, if you would not be able reproduce the error I have the console logs that I could send you in a PM?

    It does not hamper it from working, and the error doesn't pop up when you put the PC in the combat tracker. But might be something you would want to look into?

    Thanks!

    Update
    I just tried it in a new campaign and the error doesn't pop up I have added a few new extension recently, I will try to figure out if there is a conflict... sorry I was quite convinced it was due to the new FGU update.
    Last edited by vaughnlannister; September 26th, 2020 at 20:29.

  2. #72
    Quote Originally Posted by vaughnlannister View Post
    Hi Silentruin,

    Since the recent FGU update, I've been getting a error from your Polymorph Extension

    To reproduce this error:
    1) PC must have the wildhsape class feature added
    2) PC must not be on the Combat Tracker
    3) Press the action tab --> triggers console error

    The error I'm seeing is quite long though, if you would not be able reproduce the error I have the console logs that I could send you in a PM?

    It does not hamper it from working, and the error doesn't pop up when you put the PC in the combat tracker. But might be something you would want to look into?

    Thanks!
    Just tried what you suggested. I had a test PC already with that ability - made sure it worked - then removed it from combat tracker - hit action tab - and no error in console. Just the usual warning about must be in combat tracker to work. You can PM me and we can look at it - but you must have some other step involved here that I'm missing. For this test this should be the only extension (just to rule anything else out) running.

  3. #73
    Quote Originally Posted by vaughnlannister View Post
    Hi Silentruin,

    Since the recent FGU update, I've been getting a error from your Polymorph Extension

    To reproduce this error:
    1) PC must have the wildhsape class feature added
    2) PC must not be on the Combat Tracker
    3) Press the action tab --> triggers console error

    The error I'm seeing is quite long though, if you would not be able reproduce the error I have the console logs that I could send you in a PM?

    It does not hamper it from working, and the error doesn't pop up when you put the PC in the combat tracker. But might be something you would want to look into?

    Thanks!

    Update
    I just tried it in a new campaign and the error doesn't pop up I have added a few new extension recently, I will try to figure out if there is a conflict... sorry I was quite convinced it was due to the new FGU update.
    No worries. Glad it wasn't me

  4. #74
    Ok

    Found it, was due to the new Character Sheet effects extension, so indeed it was not you lol :P

  5. #75
    shez found an issue with Wild Shape and in the course of trying to figure out what it was I found a few bugs involving feature "Elemental Wild Shape" and getting it to properly allow air,water,fire, or earth elemental wild shape transformation. This also lead to finding a spelling error in a druid level check name that would cause an ERROR in the console (and failure) if it ever reached that far into the check.

    New version is out there.

    V1.6 - Bug fixes for Wild Shape when using circle forms druid level checks and also for elemental wild shape feature allowing fire,air,earth, or water elemental as special non beast wild shape option.

  6. #76
    Great thanks appreciate how thorough you are with keeping your extension working perfect !!!

  7. #77
    Months ago, Polymorphism and one click+One click druid were compatible at one time as I had been using both together for some time. I then wrote Silentruin and rob2e. Silentruin responded out of respect while rob2e for some unknown reason got upset when in fact there was issue with both codes (rob2e did respond to me in his discord and not very kindly at that). only in the past 2 months (June/July time frame 2020) has both programs become non compatible. They will for some reason cancel either out. So to resolve the problem I asked my 15-18 players which one they prefer to use. They chose polymorphism, its easier to use, its way more powerful, and there are several other functions that polymorphism allows players to do that currently no other mod or extension does.

    1. Polymorphism allows players full control over an NPC such as ending the NPCs turn whereas before I had to end all NPC turns, do you know what thats like when you have 6 players dropping constructs, polymorphing, shapechanging, calling forth spirits.
    2. More than 1 NPC can now be controlled by players, i.e. ranger can use a pack mule, as well as have a pet, a wizard can have a horse as well as a familiar and call forth an elemental. (Before, FGU only allowed for control of one PC/NPC).
    3. Yes, only the GM can add the NPC from the NPC tab, but thats ok since some players have a tendency to fudge. This is the best thing of all because it is a simple drop and drag, no typing code, no recreating a monster from the monster database
    4. The poly can also be used for disguise, shapechange (works great for shapeshifters), and polymorph of course.

    There is more that can be done with polymorphism but have not got that far. Best of all when an issue or a problem arises Silentruin is on top of it, just like when I sent him a confusing message message about why the druid could not shapechange into an elemental wild shape. Silentruin fixed that issue that night and logged into my game and fully tested it out on the players character. He then updated his Poly ext to version 1.6 and now the players druid "Riptide" is happier than a lark.

    In my personal humble opinion and those of my players Polymorphism does what it says it does and more. Thus to resolve the conflict between the 2 programs, one click druid and one click more cannot be used together.

  8. #78
    Quote Originally Posted by shezingzh View Post
    Months ago, Polymorphism and one click+One click druid were compatible at one time as I had been using both together for some time. I then wrote Silentruin and rob2e. Silentruin responded out of respect while rob2e for some unknown reason got upset when in fact there was issue with both codes (rob2e did respond to me in his discord and not very kindly at that). only in the past 2 months (June/July time frame 2020) has both programs become non compatible. They will for some reason cancel either out. So to resolve the problem I asked my 15-18 players which one they prefer to use. They chose polymorphism, its easier to use, its way more powerful, and there are several other functions that polymorphism allows players to do that currently no other mod or extension does.

    1. Polymorphism allows players full control over an NPC such as ending the NPCs turn whereas before I had to end all NPC turns, do you know what thats like when you have 6 players dropping constructs, polymorphing, shapechanging, calling forth spirits.
    2. More than 1 NPC can now be controlled by players, i.e. ranger can use a pack mule, as well as have a pet, a wizard can have a horse as well as a familiar and call forth an elemental. (Before, FGU only allowed for control of one PC/NPC).
    3. Yes, only the GM can add the NPC from the NPC tab, but thats ok since some players have a tendency to fudge. This is the best thing of all because it is a simple drop and drag, no typing code, no recreating a monster from the monster database
    4. The poly can also be used for disguise, shapechange (works great for shapeshifters), and polymorph of course.

    There is more that can be done with polymorphism but have not got that far. Best of all when an issue or a problem arises Silentruin is on top of it, just like when I sent him a confusing message message about why the druid could not shapechange into an elemental wild shape. Silentruin fixed that issue that night and logged into my game and fully tested it out on the players character. He then updated his Poly ext to version 1.6 and now the players druid "Riptide" is happier than a lark.

    In my personal humble opinion and those of my players Polymorphism does what it says it does and more. Thus to resolve the conflict between the 2 programs, one click druid and one click more cannot be used together.
    In defense of the other extension programmer - there is no guarantee we can make an extension compatible with someone else's extension. As I keep saying in all my extensions and pretty much wherever I can (it's a thing with me), FGU and any other extension can break any other extension at any time. The best any of us can do is make sure we can run with the extensions we run with. It's why even though many of you tell me its compatible with other things - I'm never going to personally admit that unless I run with those things also.

    So don't be too hard on other extension programmers - its the nature of the beast we ride when writing extensions. As long as you understand that when talking to an extension developer going in - I think you can have a good conversation with them. Don't expect them to drop everything to fix some incompatibility with something that they don't use.

    EXTENSIONS = RISK

    My mantra when I put any of these for sale to the public.
    Last edited by SilentRuin; October 4th, 2020 at 16:39.

  9. #79
    I have partnered with Grim Press to handle sales and promo of this extension. I'm just to lazy to bother

  10. #80

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
FG Spreadshirt Swag

Log in

Log in