FG Spreadshirt Swag
  1. #1
    Sulimo's Avatar
    Join Date
    Dec 2014
    Pacific Time Zone

    File Creation Date issue (Core-RPG)

    I was able to reproduce this in Core-RPG (after experiencing the issue in Rolemaster Classic), no extensions. I was originally working to add LoS to a module for FGU (following the instructions here) when I discovered the issue. The FGU/LoS part is not necessary to recreate the issue though.

    Here are the steps to reproduce:
    1. Create a new Campaign in FGC (Core-RPG ruleset).
    2. Enter Story, NPCs, Encounters, Quests, Items, Parcels, Images, etc.
    3. Once finished, export to a module (/export).
    4. Extract the Module file to a folder (I am using the built in Windows functionality, I do not have any 3rd party zip tools installed).
    5. Try to zip the files again (only the files, no folders are being zipped).
    6. It will fail with 'File not found or no read permission' error (see screen shot).


    I have never had a problem zipping handmade module files (by hand editing the XML), so this was new to me. I tried on two different computers and got the same error.

    I believe I have found where the issue is coming from, I can fix it manually, but it would be nice if FGC did not introduce the issue during the /export process.

    After doing a lot of digging, and a lot of dead ends (NTFS Permissions were not the issue, etc.), the issue, I believe, has to do with when FGC exports a module, it is doing something strange to the Create Date for the files inside of the .mod file.

    Here is a screen shot of what I am referring to, the file on the left is from the images folder of the campaign (before I exported the module), the file on the right is from the .mod file (renamed to .zip and extracted).

    As you can see, the file from the .mod file has a creation date of January 19, 1601 (!).

    I am guessing there is a signed integer somewhere causing this particular issue?

    I downloaded a tool to change the creation date of the file to something more recent, and after that, I can successfully zip the files back up and rename to .mod.
    Shots from the tool I used to change the file dates:

    So it looks like for some reason the /export process is setting the file create date improperly (to the year 1601), and that is causing the zip process to fail (using the built in Windows .zip tool).

    System specs:
    Windows 10 (tried on both 1909 and 2004).
    FGC Version 3.3.11
    Blank Core-RPG campaign created for the test, one Story, one NPC, one Encounter, one Map, one item, one Parcel, one note, and one quest created.
    Let me know if there are other specs you might be interested in.

    I can zip up the core-rpg campaign folder if you want to have that as a reference, just let me know.

    I realize that part of this is a Windows bug, and I will be raising that to Microsoft as soon as I can (the file date should not matter to the zip tool).
    Not all who wander are lost.

  2. #2
    Zacchaeus's Avatar
    Join Date
    Dec 2014
    Interesting and I can reproduce this.

    It's not something I've ever seen before since I use 7zip and on testing 7zip doesn't have an issue zipping everything back up but the windows compressor does apparently.
    If there is something that you would like to see in Fantasy Grounds that isn't currently part of the software or if there is something you think would improve a ruleset then add your idea to the wish list http://fg2app.idea.informer.com/

  3. #3
    LordEntrails's Avatar
    Join Date
    May 2015
    -7 UTC
    Blog Entries
    So what you are saying is that you did not create those files 400 years ago?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
5E Character Create Playlist

Log in

Log in