Starfinder Playlist
Page 1 of 2 12 Last
  1. #1

    Error when loading a game

    Hello guys. I started to get this error when I load my campaigns and people when they join get a bunch of errores too. Any idea what might be causing this? Thank you.
    Im using FG Classic btw.

    Script Error: [string "scripts/manager_gamesystem.lua"]:41: attempt to call field 'useFGUDiceValues' (a nil value)
    Ruleset Warning: chat: Could not find icon (icon)

    Cheers!

    EDIT: Solved, just looked the updated version on (https://www.fantasygrounds.com/forum...53-5E-Enhancer) and fixed it. Thanks all for the help!!!
    Last edited by Chudstar; July 31st, 2020 at 20:05.

  2. #2
    Trenloe's Avatar
    Join Date
    May 2011
    Location
    Isle of Wight, UK (for a bit)
    Posts
    27,566
    Most script errors are caused by incompatible/old extensions.

    What ruleset are you using?
    What extensions are you running?
    FG Con 16 Fantasy Grounds Online RPG Convention - Postponed New date To Be Confirmed.
    Register at www.fg-con.com for all the latest info.

    Private Messages: My inbox is forever filling up with PMs. Please don't send me PMs unless they are actually private/personal messages. General FG questions should be asked in the forums - don't be afraid, the FG community don't bite and you're giving everyone the chance to respond and learn!

  3. #3
    Quote Originally Posted by Trenloe View Post
    Most script errors are caused by incompatible/old extensions.

    What ruleset are you using?
    What extensions are you running?
    I'm running Combat Enhancer and its extensions, the Token Helper. That's pretty much it. The ruleset is 5e

    It started to happen after the last 2 updates. Before I never had any errors.

  4. #4
    Trenloe's Avatar
    Join Date
    May 2011
    Location
    Isle of Wight, UK (for a bit)
    Posts
    27,566
    Quote Originally Posted by Chudstar View Post
    I'm running Combat Enhancer and its extensions, the Token Helper. That's pretty much it. The ruleset is 5e

    It started to happen after the last 2 updates. Before I never had any errors.
    Community extensions don't update themselves - so they need to be checked for compatibility, especially after a FG update.

    So, make sure you've visited the product page/thread for each extension you're running and get the latest version - install these. See if you're still getting any errors in your campaign.

    If you are still getting errors, the steps to check what might be causing script errors are:
    1) Create a brand new campaign without any extensions. Make sure that works OK.
    2) Add in the extensions you're using one-by-one into this brand new campaign, and load the campaign after enabling each extension - see which extension/s cause the error.
    FG Con 16 Fantasy Grounds Online RPG Convention - Postponed New date To Be Confirmed.
    Register at www.fg-con.com for all the latest info.

    Private Messages: My inbox is forever filling up with PMs. Please don't send me PMs unless they are actually private/personal messages. General FG questions should be asked in the forums - don't be afraid, the FG community don't bite and you're giving everyone the chance to respond and learn!

  5. #5
    Quote Originally Posted by Trenloe View Post
    Community extensions don't update themselves - so they need to be checked for compatibility, especially after a FG update.

    So, make sure you've visited the product page/thread for each extension you're running and get the latest version - install these. See if you're still getting any errors in your campaign.

    If you are still getting errors, the steps to check what might be causing script errors are:
    1) Create a brand new campaign without any extensions. Make sure that works OK.
    2) Add in the extensions you're using one-by-one into this brand new campaign, and load the campaign after enabling each extension - see which extension/s cause the error.
    Thanks, I will check this and report back. I'm pretty sure Combat Enhancer is no longer being update, and I don't know of any other updated alternative to it.

  6. #6
    LordEntrails's Avatar
    Join Date
    May 2015
    Location
    -7 UTC
    Posts
    12,459
    Blog Entries
    9
    5E Combat Enhancer (https://www.fantasygrounds.com/forum...bat-extension)) has never been supported with FGU. And it is no longer being supported by the developer in FGC but a few folks in teh community I think have been posting updates to it.

    5E Enhancer (https://www.fantasygrounds.com/forum...53-5E-Enhancer)was written by the same developer to port most of the functionality over to work with FGU and I don't think it was ever intended to work with FGC. But as you noticed, it is not currently supported either. I believe the dev decided it was too much work to keep up with all the changes to FGU. You may check the thread and see if any of the other users of the extension can help resolve your issue or you might just have to stop using the extension until it is updated and supported once again.

  7. #7
    Quote Originally Posted by LordEntrails View Post
    5E Combat Enhancer (https://www.fantasygrounds.com/forum...bat-extension)) has never been supported with FGU. And it is no longer being supported by the developer in FGC but a few folks in teh community I think have been posting updates to it.

    5E Enhancer (https://www.fantasygrounds.com/forum...53-5E-Enhancer)was written by the same developer to port most of the functionality over to work with FGU and I don't think it was ever intended to work with FGC. But as you noticed, it is not currently supported either. I believe the dev decided it was too much work to keep up with all the changes to FGU. You may check the thread and see if any of the other users of the extension can help resolve your issue or you might just have to stop using the extension until it is updated and supported once again.
    Thanks for the heads up. I was browsing through the post and I saw an updated version of the extension by another user. I already asked in that forum post to the guy that made the updated version, but do you know if I can replace the new .ext files with the other ones in the extensions folder of FGC? Thanks and sorry to bother you. Im kind of new to FG

  8. #8
    LordEntrails's Avatar
    Join Date
    May 2015
    Location
    -7 UTC
    Posts
    12,459
    Blog Entries
    9
    Personally I would move the old version into an archive or history file. If you overwrite it with the new one and the new one doesn't work, then you don't have a backup.

  9. #9
    Quote Originally Posted by LordEntrails View Post
    Personally I would move the old version into an archive or history file. If you overwrite it with the new one and the new one doesn't work, then you don't have a backup.
    Did it and it worked. Thanks for the help guys!!

  10. #10
    Quote Originally Posted by Chudstar View Post
    Hello guys. I started to get this error when I load my campaigns and people when they join get a bunch of errores too. Any idea what might be causing this? Thank you.
    Im using FG Classic btw.

    Script Error: [string "scripts/manager_gamesystem.lua"]:41: attempt to call field 'useFGUDiceValues' (a nil value)
    Ruleset Warning: chat: Could not find icon (icon)

    Cheers!

    EDIT: Solved, just looked the updated version on (https://www.fantasygrounds.com/forum...53-5E-Enhancer) and fixed it. Thanks all for the help!!!
    This link is bad? I recently started getting this script error

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
SWADE Playlist

Log in

Log in