Fantasy Grounds Fridays Pre
Page 6 of 16 First ... 45678 ... Last
  1. #51
    Update:

    After the above dced, I restarted only the DM PC - again, lost connecting approx 20-21min with same error message.
    After that, started DM PC, logged into it with 2nd PC - stable for 3.5 hours and still running. This time the 2nd PC dced (~2 hrs in) but could reconnect to host.
    (all scenarios fully afk, no interaction with the program)

    Update:

    Another day, another testing run.

    Test 1 - PC1 Hosting (cloud, public), PC2 joining - running for approx 4.5 hrs until it lost connection.
    Test 2 - PC1 Hosting (cloud, public), noone joining - running 9 minutes until it lost connection (10-25 min seems the norm)
    Last edited by Valhingen; August 7th, 2020 at 17:05.

  2. #52
    8/7/2020 - Running FGU Unlimited Edition, D&D 5e. Players using free basic version. They cannot connect to y Lan game (worked fine last week). Tried putting it to a private cloud, and they cannot see it. Ports are forward. Any ideas?

    Resolved - They had to re-enter the external IP address.
    Last edited by Karykzen; August 7th, 2020 at 23:19.
    /<arykzen
    Unlimited License Holder.

  3. #53
    LordEntrails's Avatar
    Join Date
    May 2015
    Location
    -7 UTC
    Posts
    12,052
    Blog Entries
    9
    Quote Originally Posted by Karykzen View Post
    8/7/2020 - Running FGU Unlimited Edition, D&D 5e. Players using free basic version. They cannot connect to y Lan game (worked fine last week). Tried putting it to a private cloud, and they cannot see it. Ports are forward. Any ideas?
    Please post your logs as requested in the OP.

    Check your port forwarding. Routers often update internal IP addresses but your port forward will not follow/update. Make sure your connection is private. Also see the "Connections Explained" thread in the house of Healing for more ideas.

  4. #54
    Quote Originally Posted by Moon Wizard View Post
    Did the player just have updates stop (i.e. no chat/dice/updates); or did it boot them back to launcher screen automatically?

    Thanks,
    JPG
    Sorry for the delay, my player didn't see the email I sent him asking for more details, until I got him to check again tonight.
    "FGU was unresponsive for a few seconds, then I was disconnected from the campaign. The log of errors window appeared and once a clicked on the 'Compose List' button and closed the window, the launcher screen automatically appeared. "

    He had the same thing happen again tonight. He father was also connected using the same broadband service. This time his father also disconnected, but that appears to be different, as my console logs showed a disconnect for him, whereas the son was shown as still connected and had to be kicked. The father also got a message that something was updating, so it was probably another program that interrupted his connection. I have attached the logs from tonight to this.

    Edit. Oh, and I also accidently closed Fantasy Grounds, and had to restart it at one point. So that might look a little weird in the logs.
    Attached Files Attached Files
    Last edited by GrumpyOldAndy; August 7th, 2020 at 23:42.

  5. #55
    My last report for now since it seems repeatable every single time.

    PC 1 hosting (public, cloud, premium) - PC 2 joining - runtime without discconnect approx. 7 hrs (then I shut it down to go to bed)
    PC 1 hosting (public, cloud, premium), noone joining - lost connection approx 30min later

    While the overall issue of losing connection can probably have countless reasons (within FGU, my own connection whatever), there seems to be a very clear difference between hosting as DM solo (say you wait for your players) and having someone connected. Maybe whatever the reason for this is, is also affecting other disconnects (just guessing of course).

  6. #56
    There was a post on the cloud network library developers Discord stating that he was a couple days out from an update that I believe should help with many of the issues reported:
    "New feature coming soon: Auto reconnect if connection to a relay server is lost (including selecting a new physical relay server when necessary). No more dropped connections when users experience a connection hiccup that temporarily prevents communication with their relay server, and automatic failover if one of the relay servers experiences technical issues. The only thing that should drop a connection now is the transport layer disconnect timeout. Your application won't need to change at all, it's all automatic. To be released in the next couple days. Cheers"

    @Valhingen,
    Thanks again for additional checking. I've forwarded the solo timeout question to the library developer.

    @GrumpyOldAndy,
    Thanks for additional logs. It looks like the first player logs are tied to the server being closed; and the second player logs shows the lost connection to relay server issue. I think this may be helped by above coming update.

    Regards,
    JPG

  7. #57
    This started last week (8/6 - Thursday night) for me. Was working fine up until then. Thursday night players started reporting that they could not find me in the lobby server. After restarting the table, the quick ones were able to connect, but after about 5 minutes, no one could find me. I fired up the laptop and parked it in the lobby to monitor. Server dropped out, came back, dropped out, came back, about 3 or 4 times in the first 3-5 minutes of launching the table. After that, it never showed back up in the lobby. After several hours of trying to figure out what was happening, I left it on overnight and checked the network and server logs, and could not find any indication whatsoever that FGU ever even attempted to try to reconnect after the 3rd time.

    Further testing the following day, I built a new campaign in case it was something in my campaign that got corrupted and was causing errors. Worked flawlessly as if there was never a problem to begin with. Restarted multiple times to be sure, and not a single issue. So... I set out to rebuild the module I was planning on running on Saturday again from scratch. No a single issue, and players were able to log in and roll up characters.

    Next day (Saturday), relaunched the campaign to get set up for the session... and back to square one. Through the rest of the weekend, same results. Brand new from-scratch campaigns ran flawlessly. The next time they were loaded, total failure within 5 minutes of launch. I could connect to other tables just fine.

    More testing. Even went as far as reinstalling FGU, reinstalling windows, blowing out firewall and rebuilding that one rule at a time. Same with Verizon FiOS router. Disabled A/V (no VPN, no proxy, etc.) and even put the system in the DMZ. The only error in the console was that "due to software on the host system" is a totally false report. WireShark shows nothing anomalous. Even happens in Safe Mode. 30-years as a network engineer and "agency" cyber expert, and I can positively conclude that this is not a network issue on my end. System specs include 2 x 8-core CPUs, 2 x GPUs, 256GB RAM, and more internal storage on 2 x RAID5 arrays than anyone could reasonably need.

    Anyway, doing some more tracing and it is definitely the loading of ANY module (fresh install, so I currently have ONLY SmiteWorks content default content from the initial reinstall of FGU). As soon as I load ANYTHING, the network drops the cloud server. After the module loads, it comes back online. After the THIRD time, the system NEVER attempts to reconnect to the cloud server again.

    No players connected. They never get the chance.

    Link to the Logs and copy of test module sent via email.

    Ruleset = 5E
    Modules tested with = PHB, DMG, MM. Any 3 will cause this to happen. I was hoping to get buy with at least the core 3 for a session tonight....
    Last edited by Lou Ciphor; August 11th, 2020 at 21:18. Reason: added ruleset & modules

  8. #58
    Responded via e-mail.

    JPG

  9. #59
    Hi!

    Has anyone tried to start a campaign and had the "Network engine not ready"? Not sure how to fix this.

    Thanks for any help

  10. #60
    I'm surprised to see that error message. It means that the network engine objects in the program are not initialized.

    * What is the make/model/specifications of your machine?
    * What OS and version are you running on?
    * How does the machine connect to the network? (i.e. wired, standard wifi, mobile wifi, etc.)
    * Anything unique to your environment/machine that would be different than other users?

    Regards,
    JPG

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
SWADE Playlist

Log in

Log in