Joshua Stream Pre
Page 4 of 7 First ... 23456 ... Last
  1. #31
    Change line 88 from return DB.getChild("RFIA_Root." .. ROLLS .. "." .. SAVES); to return DB.getChild("RFIA_Root." .. ROLLS, SAVE);

    I found the error. In your previous post you left the S off the end of SAVE when it should have said SAVES. Of course I didn't know this because I was following your guide. Your longer guide had the correct spelling and it no longer gives me an error. Thank you.

  2. #32
    Well done, Bokeelia.

    That is a perfect example of the code blindness I was talking about in an earlier post. I knew I had written SAVES so every time I looked at my post, that is what I saw! It also shows the advantage of the old trick of literally cutting and pasting everything you do into a separate log when trying to track down an error.

    I am going to go and edit that earlier post if I can, just in case anyone else gets stalled by it.

  3. #33
    Thank you for this Bokeelia!

    I will update this in a release soon. Still being driven crazy from debugging my other extension.

    Will do this one evening this week.

  4. #34
    Does the "fixed for FGC" version also work in FGU? If so, then we could ask Houndy to include the changes in the release version--but only if it works in both FGC and FGU as this version of RFIA+ is his FGU modified version.

  5. #35
    Hi, zuilin. Yes, it does. The only thing stopping it from working in FGC is, as far as I was able to tell, is a difference in behaviour between the DB.getChild function in FGC and FGU. All I did was change those lines to match the declared specification in the API documentation. Houndy's code uses that FGC friendly way of using that function in a number of other places in the code. I am guessing that in FGU you can get away without supplying the second parameter and it still works. Maybe the FGU API documentation should be updated to list that parameter as optional if that is expected behaviour.

  6. #36
    Have just updated so that it should work with FGC with Bokeelia's suggestions.

    Please let me know if any issues.

  7. #37
    Another quick update:

    • 0.18
      • Fixed bug with D100 where it rolled two D10s instead of one.
      • Added a select random NPC and a select random PC button. Please note, that the limitations of LUA require one second between each button press to make this random.
      • Possibly added compatibility with Better Menus addon, but cannot test this myself as I do not run FGC, so will need someone else to please!
    Last edited by Houndy; May 31st, 2020 at 22:03.

  8. #38
    Houndry,

    The Better Menu now shows RFIA. Thanks for fixing that as I had disabled Better Menu's due to it not showing up. The extension is now throwing out some errors upon loading in.

    Script Error: [string "RFIA_CreateRequest:select_random_pc_button"]:1: 'end' expected near '<eof>'
    Script Error: [string "RFIA_CreateRequest:select_random_npc_button"]:1: 'end' expected near '<eof>'
    Runtime Notice: s'Adding new Golarion based languages...'
    Runtime Notice: s'menulist.lua' | s'populateMenuList: Adding custom menu--->' | s'rMenu' | { s'sPath' = s'RFIA_Root', s'sButtonCustomText' = s'RFIA', s'sToolTip' = s'RFIA_window_title', s'sRecord' = s'RFIA_CreateRequest' }
    Runtime Notice: s'menulist.lua' | s'populateMenuList: Adding custom menu--->' | s'rMenu' | { s'sPath' = s'', s'sToolTip' = s'sidebar_tooltip_moduleselection', s'sRecord' = s'moduleselection' }
    Ruleset Warning: chat: Could not find icon (icon)
    Last edited by Bokeelia; June 1st, 2020 at 04:20.

  9. #39
    Thanks Bokeelia,

    I will look into getting fgc tonight, that's gonna be easier way. As long as I can test for free, I will start testing in FGC also.

    For now the previous version will work, just won't support the menu add on.

  10. #40
    Bug (?) Report:

    Are you using the latest version of FGU and the extension?
    Nope! Using the latest version of FGC and the extension.

    Are you using any other extensions?
    Tried it with both other extensions and none. Same error.

    What is the problem?
    Get an error on load, but all the functionality seems to work.

    Try to describe the steps to recreate the error.
    Loaded the game, as per normal.

    If possible please copy and paste your console log:
    Annotation 2020-06-01 094733.png

    Awesome extension. Like I said above, despite the error, everything seems to be working fine.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
5E Character Create Playlist

Log in

Log in