Page 3 of 3 First 123
  1. #21
    Trenloe's Avatar
    Join Date
    May 2011
    Location
    Newcastle, UK (for a bit)
    Posts
    26,076
    Also ask the players to check if they have "Cross-platform compatibility mode for Linux and Mac" enabled in their FG settings. When I was doing some download testing a few months ago on a low spec PC this being enabled increased module load time from 3 minutes to 20 minutes!
    FG Con 16 Fantasy Grounds Online RPG Convention - Postponed New date To Be Confirmed.
    Register at www.fg-con.com for all the latest info.

    Private Messages: My inbox is forever filling up with PMs. Please don't send me PMs unless they are actually private/personal messages. General FG questions should be asked in the forums - don't be afraid, the FG community don't bite and you're giving everyone the chance to respond and learn!

  2. #22
    Ok, for those reading this. I did some troubleshooting with FG discord (fgc_support). Looks like the problem was that my computer's antivirus was blocking the connection. I added everything FG to my AV whitelist and it appears to work! Thanks to Talyn on the discord.

  3. #23
    Correction: This did not solve my issue. I played a game last night and the modules still would not load for players. One player had a partial load of one of the Players Guides, but no luck with PHB or XGE.

  4. #24
    Solution Found:

    Bottom Line: VPN solution solves the download issue

    When you look at my tracert 8.8.8.8 (to google), you can see that there is an issue with the second hop (as it always has a timeout, then slowly responds). I have AT&T but the issue may be applicable to other ISPs. The issue appears to be related to the hop leaving my external gateway (vs. the internal router - which I have port forwarded). I spent an hour on the phone waiting for AT&T technical support (to modify this external firewall) and finally gave up. In the main menu of Fantasy Ground, the Run Test is successful (so something is getting through).

    LogMeIn Hamachi looked the “easiest” in the old forum posts so I opted to try it. The setup has changed a bit so I created another set of notes for my players. I’ve genericized this for the public on a google doc here:
    https://docs.google.com/document/d/1...it?usp=sharing

    I’ve had four players connect and download books and didn’t have the gray map issue while playing. I’ve got two more games over the next ten days where I’ll transition players to this setup. Hamachi is limited to five total for the free version. There are notes about creating multiple virtual networks but I opted to purchase the base VPN for up to 32 players (since I’m running three games with a total of twenty or so players).

    More technical stuff. When you set up your virtual network, the software creates another network adapter (Hamachi one) that you can see with an ipconfig command. Since the existing network adapter is still in place, this may explain why the Run Test command still works.

    Let me know if I can help to explain this better or to get the word out to other players having issues like these. Fantasy Grounds, though it has a steep learning curve, is a fantastic program and the community is great. I’m glad I opted for the FG VTT route.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Joshua Stream Pre

Log in

Log in