Page 2 of 4 First 1234 Last
  1. #11
    Id really like to work on the FONT issue. I've found the font folder in the ruleset and the associated base.xml. Experimenting with it, I've dropped a couple of different ttf fonts into the folder and tried to reference them in the base.xml doc insteag of the fgf font references. For instance Ichanged several of them to calibri.ttf. However when I load the ruleset fails to load with an error:

    [1/13/2020 8:23:49 PM] [<color="red">ERROR</color>] Error loading ruleset XML file. [Star Wars EotE] [graphics/fonts/base.xml]: 'name' is a duplicate attribute name. Line 4, position 46.
    [1/13/2020 8:23:49 PM] [NOTICE] Tabletop scene exiting.
    [1/13/2020 8:23:49 PM] [<color="red">ERROR</color>] Object (customdie) deleted without cleaning up attached Lua object.
    [1/13/2020 8:23:49 PM] [<color="red">ERROR</color>] Object (customdie) deleted without cleaning up attached Lua object.
    [1/13/2020 8:23:49 PM] [NOTICE] Launcher scene starting.

    If anyone can help with how to fix the fonts its greatly apperciated.

  2. #12
    LordEntrails's Avatar
    Join Date
    May 2015
    Location
    GMT -7
    Posts
    8,773
    Blog Entries
    9
    Quote Originally Posted by punisher5150 View Post
    Id really like to work on the FONT issue. I've found the font folder in the ruleset and the associated base.xml. Experimenting with it, I've dropped a couple of different ttf fonts into the folder and tried to reference them in the base.xml doc insteag of the fgf font references. For instance Ichanged several of them to calibri.ttf. However when I load the ruleset fails to load with an error:

    [1/13/2020 8:23:49 PM] [<color="red">ERROR</color>] Error loading ruleset XML file. [Star Wars EotE] [graphics/fonts/base.xml]: 'name' is a duplicate attribute name. Line 4, position 46.
    [1/13/2020 8:23:49 PM] [NOTICE] Tabletop scene exiting.
    [1/13/2020 8:23:49 PM] [<color="red">ERROR</color>] Object (customdie) deleted without cleaning up attached Lua object.
    [1/13/2020 8:23:49 PM] [<color="red">ERROR</color>] Object (customdie) deleted without cleaning up attached Lua object.
    [1/13/2020 8:23:49 PM] [NOTICE] Launcher scene starting.

    If anyone can help with how to fix the fonts its greatly apperciated.
    The first things would be to look at the file "graphics/fonts/base.xml"
    Then look on line 4, see the attribute 'name'? It's duplicate. Then do a Find or Find in Files for the same and see if you can figure out where else it is used. Then figure out which of the two you can delete or rename.

    Then see if that works and what errors happen next. Track down one at a time :O

    Current Projects: Ultimate Undermountain (NYDUM)
    Community Contributions: Gemstones, 5E Quick Ref Decal, Adventure Module Creation, Dungeon Trinkets
    DMsGuild Content: Balance Disturbed (Adventure), Dungeon Room Descriptions
    FG Product Reviews: Virtual Scribe Reviews

  3. #13
    OK so I was pretty sure that was the problem since I was using the same font for multiple items listed in the base.xml, but I was basing the naming structure on the way the existing ttf fonts were named. If I want to use the same font for multiple items in the ruleset that means I would have to name the font simply somethng like: calibri_1, calibri_2, etc etc? to avoid the error? That seems like the simple fix.

  4. #14
    LordEntrails's Avatar
    Join Date
    May 2015
    Location
    GMT -7
    Posts
    8,773
    Blog Entries
    9
    Sorry, that's beyond my knowledge, but, I would not think so....

    I assume (!) That you are defining it twice and only need to define e it once, then everywhere else just reference or use it. I only poke at code though, so I'm stretching here.

    Hopefully one of the folks who actually knows code can clarify.

    Current Projects: Ultimate Undermountain (NYDUM)
    Community Contributions: Gemstones, 5E Quick Ref Decal, Adventure Module Creation, Dungeon Trinkets
    DMsGuild Content: Balance Disturbed (Adventure), Dungeon Room Descriptions
    FG Product Reviews: Virtual Scribe Reviews

  5. #15
    Trenloe's Avatar
    Join Date
    May 2011
    Location
    Newcastle, UK (for a bit)
    Posts
    24,604
    Quote Originally Posted by punisher5150 View Post
    OK so I was pretty sure that was the problem since I was using the same font for multiple items listed in the base.xml, but I was basing the naming structure on the way the existing ttf fonts were named. If I want to use the same font for multiple items in the ruleset that means I would have to name the font simply somethng like: calibri_1, calibri_2, etc etc? to avoid the error? That seems like the simple fix.
    You should be able to use the same TTF font for multiple FG <font> definitions.

    Please post the graphics/fonts/base.xml file that raises the error.
    FG Con 16 Fantasy Grounds Online RPG Convention - Friday April 24th to Sunday April 26th, 2020
    Register at www.fg-con.com for all the latest info.

    Private Messages: My inbox is forever filling up with PMs. Please don't send me PMs unless they are actually private/personal messages. General FG questions should be asked in the forums - don't be afraid, the FG community don't bite and you're giving everyone the chance to respond and learn!

  6. #16
    Quote Originally Posted by Trenloe View Post
    You should be able to use the same TTF font for multiple FG <font> definitions.

    Please post the graphics/fonts/base.xml file that raises the error.
    Let me play around with the information you and Lord Entrails posted for a couple of days and see what I can do. I am trying to understand how the coding works. If I still can't figure it out I will post the file for some input. Thanks! I want to do my part in keeping this ruleset alive depsite the bad news coming from FFG!

  7. #17
    OK so I've gotten the program to load with no font errors. Not sure if they are all working though. It seems like italics and bold selections in the story windows (cntrl b and cntrl i) do not work. And when highlighting a word there is no option to make it bold or italic through the radial menu. It probably needs some cleaning up. The next question: does anyone know what fonts were used to create the .fgf fonts for FG Classic? (I simply used some fonts as a test font). If so I believe I can duplicate the look of the original classic story windows etc.

    That being said, the links do not work from the story windows (or other windows as far as I can tell.) Any idea how to fix those?

    Attached is the base.xml file from the graphics/font folder. One note is that I left the fgf references for now. But I know those won't be needed anymore and can be removed.

    The fonts I used (ITC-Symbol etc etc) are located in the graphics/fonts/ITC_Symbol subfolder. I can upload that folder if needed.
    Attached Files Attached Files
    Last edited by punisher5150; January 17th, 2020 at 20:49.

  8. #18
    Just as a follow-up, I tested the dice rolling again today and was unable to get the error to occur, it looks like whatever was behind that problem has been handled in a FGU update.

  9. #19
    damned's Avatar
    Join Date
    Mar 2011
    Location
    Australia
    Posts
    19,529
    Blog Entries
    1
    Quote Originally Posted by punisher5150 View Post
    OK so I've gotten the program to load with no font errors. Not sure if they are all working though. It seems like italics and bold selections in the story windows (cntrl b and cntrl i) do not work. And when highlighting a word there is no option to make it bold or italic through the radial menu. It probably needs some cleaning up. The next question: does anyone know what fonts were used to create the .fgf fonts for FG Classic? (I simply used some fonts as a test font). If so I believe I can duplicate the look of the original classic story windows etc.

    That being said, the links do not work from the story windows (or other windows as far as I can tell.) Any idea how to fix those?

    Attached is the base.xml file from the graphics/font folder. One note is that I left the fgf references for now. But I know those won't be needed anymore and can be removed.

    The fonts I used (ITC-Symbol etc etc) are located in the graphics/fonts/ITC_Symbol subfolder. I can upload that folder if needed.
    What you would likely do with the fonts is start with Noto Sans and edit the font character set to add in the special dice symbols over the lease used characters. At some point this will create an issue but it seems unavoidable really.

    MoreCore - Generic Ruleset
    --- Projects ---
    Extensions | Tutorials | MoreCore | MoreCore Themes | Call of Cthulhu | Maelstrom | FG Con

  10. #20
    Trenloe's Avatar
    Join Date
    May 2011
    Location
    Newcastle, UK (for a bit)
    Posts
    24,604
    Quote Originally Posted by damned View Post
    What you would likely do with the fonts is start with Noto Sans and edit the font character set to add in the special dice symbols over the lease used characters. At some point this will create an issue but it seems unavoidable really.
    Use the same character codes as the FGF FG Classic fonts so that data will be compatible between the two version.
    FG Con 16 Fantasy Grounds Online RPG Convention - Friday April 24th to Sunday April 26th, 2020
    Register at www.fg-con.com for all the latest info.

    Private Messages: My inbox is forever filling up with PMs. Please don't send me PMs unless they are actually private/personal messages. General FG questions should be asked in the forums - don't be afraid, the FG community don't bite and you're giving everyone the chance to respond and learn!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in