Page 1 of 2 12 Last
  1. #1

    Players unable to join

    I've followed the port forwarding directions and am successful in my test connection (see attached). But my friends are unable to join my game.
    Attached Images Attached Images

  2. #2
    damned's Avatar
    Join Date
    Mar 2011
    Location
    Australia
    Posts
    19,074
    Blog Entries
    1
    Welcome Lurch0181

    Have you started/loaded the campaign? The players should be able to connect with your external ip address OR the alias once your campaign is running.

    Make sure they have a username in the first field.

    I just successfully connected to your table - and I see a swag of players

    Some advice... if you are new to this on FG - get rid of most of those extensions until you have the base sorted out... you also have a bunch of themes that conflict with each other

    MoreCore - Generic Ruleset
    --- Projects ---
    Extensions | Tutorials | MoreCore | MoreCore Themes | Call of Cthulhu | Maelstrom | FG Con

  3. #3
    Thank you Damned! However, my two friends who are trying to connect are both getting "unable to connect to host" errors. I'm at a loss on what to do.

  4. #4
    LordEntrails's Avatar
    Join Date
    May 2015
    Location
    GMT -7
    Posts
    8,453
    Blog Entries
    9
    Quote Originally Posted by Lurch0181 View Post
    Thank you Damned! However, my two friends who are trying to connect are both getting "unable to connect to host" errors. I'm at a loss on what to do.
    Are they on the same network as you? Then they should be using your internal IP address, not the alias or external IP address.

    What else can you tell us about them? Where are they? Where are you?

    Current Projects: Ultimate Undermountain (NYDUM)
    Community Contributions: Gemstones, 5E Quick Ref Decal, Adventure Module Creation, Dungeon Trinkets
    DMsGuild Content: Balance Disturbed (Adventure), Dungeon Room Descriptions
    FG Product Reviews: Virtual Scribe Reviews

  5. #5
    Quote Originally Posted by LordEntrails View Post
    Are they on the same network as you? Then they should be using your internal IP address, not the alias or external IP address.

    What else can you tell us about them? Where are they? Where are you?
    They are not on the same network, and are thus using my external IP address or alias. But we all live in the same city. We could all join the game hosted by one of them, but he isn't going to dm at the moment, they just can't join my game.

  6. #6
    damned's Avatar
    Join Date
    Mar 2011
    Location
    Australia
    Posts
    19,074
    Blog Entries
    1
    Whats your Alias please?

    MoreCore - Generic Ruleset
    --- Projects ---
    Extensions | Tutorials | MoreCore | MoreCore Themes | Call of Cthulhu | Maelstrom | FG Con

  7. #7
    1) Start by double checking your IP: https://whatismyipaddress.com/

    2) Start up the FG server so the computer is listening for incoming pings or contacts.

    3) Ping from an outside service to to see if you're getting though. Using your IP address from step 2, adding the default FG port used, 1802, at the end. Se example below. http://ping-test.org/
    Using [Your IP address]:1802, ex. '209.85.255.255:1802'.

    Ping Result 1:
    If you're getting a reply (packages are returned) your server is responding, your router is accepting inbound connections via that port, your connection is working outbound.

    If this is the case, they are probably entering the wrong alias/ip and/or password.

    Ping Result 2:
    If you lose all your packages, then there is a problem along the line there.

    Most likely either you have not set things up correctly on the router or there is a firewall either on the router or your computer blocking incoming packages.

    =====

    For myself when I started out running games on FG. I had sporadic success with connections, some evenings it would work fine, others not, but restarting the router seemed to work most of the times.

    Problem turned out being not having set up port forwarding for FG on the router to the correct port 1802 yet. Thereby the connection via the router kept getting blocked sometimes and sometimes not.
    Even if it showed a good / green connection on the connection test, didn't mean that outside pinging via a third party test website would work.

    However whenever an outside ping worked, the players could connect.

    The good news is though, that once I set things up properly on the router, I've never had any connection issues since.

    Good luck.
    Last edited by Styrmir; November 24th, 2019 at 13:38.
    Ultimate License holder, enables Demo Players to join my games for free.

    [FGU backer, extension writer]

    5E Enhancer

    Combat Enhancer 5E Classic





  8. #8
    Quote Originally Posted by damned View Post
    Whats your Alias please?
    It's in the attachment in my first post

  9. #9
    damned's Avatar
    Join Date
    Mar 2011
    Location
    Australia
    Posts
    19,074
    Blog Entries
    1
    Hi Lurch0181

    Sorry I forgot I tested joining your game already.
    Either the players have:

    1. Incorrectly entered the alias or WAN IP (maybe copy/pasted a space in there?)
    2. not entered a player name
    3. have a local firewall issue on their software
    4. you have inadvertently activated a firewall rule against their IPs only
    5. there is a routing issue between them and you

    If its working for other players and not them you might need to troubleshoot those things above or install hamachi and have the players who cannot connect do the same and connect via hamachi while the others connect normally and stop chasing your tails?

    MoreCore - Generic Ruleset
    --- Projects ---
    Extensions | Tutorials | MoreCore | MoreCore Themes | Call of Cthulhu | Maelstrom | FG Con

  10. #10
    I am actually also having this problem at the moment, and it is a strange one. I went through all the debugging with the player who couldn't connect. It really made no sense...or so I thought. I know my setup works because I just ran FGCON and have never had any player connect issues. The player can do a full tracert to me with no problems and he can also connect to another FG GM friend, so I was scratching my head. Then, when I asked for his IP, I noticed that he was connecting via IPv6. I have an older router that doesn't support it. So, I am posting this comment here for you to check the following issue: player possibly using IPv6 and you being on IPv4, where the IPv6 traffic is not being passed through because of router issues -- either because it is unsupported or you are blocking IPv6. In the very least, it's something else to check. and/or be aware of, now that we are in the IPv6/v6 transitional gray area.
    FG Wish List - http://fg2app.idea.informer.com/
    License: Ultimate [Unlicensed/Free Trial FG users can play in my games]
    Teamspeak: ts.fg-con.com (alternate server in case of trouble: voice.fg-con.com)
    Password: Dungeoneers
    FG Server Alias: cold wand bold fang

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in