1. #1

    Interface Zero 2.0 massive issue

    Hello Savages!
    I wanted to test Interface Zero 3.0 with FG this morning and I had a massive issue as you can see in the pic and with the error messages below. Did anyone else face the same issues and is there anybody from Gun Metal on the forum who could help?

    When it starts:
    Script Error: [string "scripts/launcher.lua"]:18: attempt to call field 'registerVersionMessage' (a nil value)

    When I create a new character:
    Script Error: [string "scripts/launcher.lua"]:18: attempt to call field 'registerVersionMessage' (a nil value)
    Ruleset Warning: stringcontrol: Could not find font (sheetlabelsmall) for control (streetcredpoollabel) in windowclass (charsheet_header)
    Script Error: [string "common/scripts/template_labeledvalue.lua"]:17: attempt to index global 'label' (a nil value)
    Script Error: [string "common/scripts/template_labeledvalue.lua"]:17: attempt to index global 'label' (a nil value)
    Script Error: [string "streetcredpool"]:1: attempt to index global 'CharacterSheetCommon' (a nil value)
    Script Error: [string "charsheet/scripts/iz_charsheet_header.lua"]:8: attempt to index global 'CharacterSheetCommon' (a nil value)
    Ruleset Error: window: No vertical anchor defined for control (setting) in windowclass (charsheet_header)
    Ruleset Error: window: No vertical anchor defined for control (race) in windowclass (charsheet_header)
    Ruleset Error: window: No vertical anchor defined for control (mainpowerpoints) in windowclass (charsheet_header)
    Ruleset Error: window: Control (mainpowerpointsmax) anchoring to uncalculated control (mainpowerpoints) in windowclass (charsheet_header)
    Ruleset Error: window: Control (mainpowerpointsmax) anchoring to uncalculated control (mainpowerpoints) in windowclass (charsheet_header)
    Ruleset Error: window: Control (mainpowerpointsmax) anchoring to uncalculated control (mainpowerpoints) in windowclass (charsheet_header)
    Ruleset Error: window: No vertical anchor defined for control (powerpointlabel) in windowclass (charsheet_header)
    Ruleset Error: window: No vertical anchor defined for control (powerpointseparator) in windowclass (charsheet_header)
    Ruleset Error: window: No vertical anchor defined for control (setting) in windowclass (charsheet_header)
    Ruleset Error: window: No vertical anchor defined for control (race) in windowclass (charsheet_header)
    Ruleset Error: window: No vertical anchor defined for control (mainpowerpoints) in windowclass (charsheet_header)
    Ruleset Error: window: Control (mainpowerpointsmax) anchoring to uncalculated control (mainpowerpoints) in windowclass (charsheet_header)
    Ruleset Error: window: Control (mainpowerpointsmax) anchoring to uncalculated control (mainpowerpoints) in windowclass (charsheet_header)
    Ruleset Error: window: Control (mainpowerpointsmax) anchoring to uncalculated control (mainpowerpoints) in windowclass (charsheet_header)
    Ruleset Error: window: No vertical anchor defined for control (powerpointlabel) in windowclass (charsheet_header)
    Ruleset Error: window: No vertical anchor defined for control (powerpointseparator) in windowclass (charsheet_header)
    Ruleset Warning: stringcontrol: Could not find font (sheetlabelsmall) for control (streetcredpoollabel) in windowclass (charsheet_header)
    Script Error: [string "common/scripts/template_labeledvalue.lua"]:17: attempt to index global 'label' (a nil value)
    Script Error: [string "common/scripts/template_labeledvalue.lua"]:17: attempt to index global 'label' (a nil value)
    Script Error: [string "streetcredpool"]:1: attempt to index global 'CharacterSheetCommon' (a nil value)
    Script Error: [string "charsheet/scripts/iz_charsheet_header.lua"]:8: attempt to index global 'CharacterSheetCommon' (a nil value)
    Ruleset Error: window: No vertical anchor defined for control (setting) in windowclass (charsheet_header)
    Ruleset Error: window: No vertical anchor defined for control (race) in windowclass (charsheet_header)
    Ruleset Error: window: No vertical anchor defined for control (mainpowerpoints) in windowclass (charsheet_header)
    Ruleset Error: window: Control (mainpowerpointsmax) anchoring to uncalculated control (mainpowerpoints) in windowclass (charsheet_header)
    Ruleset Error: window: Control (mainpowerpointsmax) anchoring to uncalculated control (mainpowerpoints) in windowclass (charsheet_header)
    Ruleset Error: window: Control (mainpowerpointsmax) anchoring to uncalculated control (mainpowerpoints) in windowclass (charsheet_header)
    Ruleset Error: window: No vertical anchor defined for control (powerpointlabel) in windowclass (charsheet_header)
    Ruleset Error: window: No vertical anchor defined for control (powerpointseparator) in windowclass (charsheet_header)
    Ruleset Error: window: No vertical anchor defined for control (setting) in windowclass (charsheet_header)
    Ruleset Error: window: No vertical anchor defined for control (race) in windowclass (charsheet_header)
    Ruleset Error: window: No vertical anchor defined for control (mainpowerpoints) in windowclass (charsheet_header)
    Ruleset Error: window: Control (mainpowerpointsmax) anchoring to uncalculated control (mainpowerpoints) in windowclass (charsheet_header)
    Ruleset Error: window: Control (mainpowerpointsmax) anchoring to uncalculated control (mainpowerpoints) in windowclass (charsheet_header)
    Ruleset Error: window: Control (mainpowerpointsmax) anchoring to uncalculated control (mainpowerpoints) in windowclass (charsheet_header)
    Ruleset Error: window: No vertical anchor defined for control (powerpointlabel) in windowclass (charsheet_header)
    Ruleset Error: window: No vertical anchor defined for control (powerpointseparator) in windowclass (charsheet_header)
    Attached Images Attached Images

  2. #2
    I've forwarded this forum post with all the information to Ikael, so that he can investigate. Thanks for reporting.

    Note: Without knowing anything specific about SW, it looks like either the ruleset or the IZ extension are not completely updated to the latest version. While waiting for Ikael response, can you remove the following product folders (GMGIZ20FG, PEGFGSWBASE, PEGFGSWADE) from the FG data folder under the vault subfolder; then run a new update using the FG Check for Updates button? You can access the FG data folder by using the folder icon in upper right corner of launch screen.

    Regards,
    JPG

  3. #3
    Ikael responded quickly to me via e-mail; and thinks the same thing.
    "User is using ancient version of the extension. Maybe ask him to delete it and rerun updater "

    So, please follow the directions in my previous post.

    Regards,
    JPG

  4. #4
    Thanks MoonWizard. I tried deleting the 3 dat files from the vault and FG did re-installed them but the issue persists. Ialso tried to launch my Lankhmar module and I got the error message below. Everything else works fine in Lankhmar though (including creating a new PC)...
    Runtime Notice: Host session started
    Ruleset Notice: Campaign database backup created.
    Script Error: [string "scripts/launcher.lua"]:16: attempt to call field 'registerVersionMessage' (a nil value)

  5. #5
    I noticed that you are loading an Interface Zero theme. I have found that themes can cause the newer versions of Savage Worlds to have troubles. I'm not familiar with that particular ruleset but maybe there is an update to the theme. Also as a test you might see if it works without the theme. I know that ETU will work without the theme in a crunch but I also know the theme makes it better.

    Anyways my thinking is you can clear the theme as the problem if it still gives errors without it loaded or point a finger if it stops giving errors...

  6. #6
    Thanks esmdev but I launched IZ without any theme.

  7. #7
    That error usually means that you are running a much older theme somewhere. Local folders and files can override the vault content.

    Can you check the extensions subfolder in the FG data folder and make sure there are no folders or files in that directory that look like they belong to IZ?

    Regards,
    JPG

  8. #8
    Thanks MoonWizard. This worked. I basically deleted everything I had that was linked to IZ and it worked!
    Thanks again for the great support!

  9. #9
    Great. Glad that you were able to get up and running again.

    Regards,
    JPG

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in