Dungeons & Dragons 2024 Core Rulebooks Pre-Order
Page 15 of 15 First ... 5131415
  1. #141
    I spent some time on this today and made some progress.

    Unfortunately, it is still going to require more time. There are some things that are being done differently and I'll have to untangle them before everything is going to work.

    Please be patient.

  2. #142

    Join Date
    May 2013
    Location
    East Coast USA.
    Posts
    957
    Quote Originally Posted by Jaxilon View Post
    ...
    Please be patient.
    Patience is our middle name! Just letting you know that I am still interested!

  3. #143
    I too am interested. Thanks for your persistence! Really appreciate your work.

  4. #144
    So, does anyone use an Atlatl? Has anyone noticed the way it works in GCA5 is different than it was in GCA4?

    GCA4 (notice "Atlatl W:"):
    GCA4 Atlatl.png

    GCA5 (notice no Atlatl shown):
    GCA5 Atlatl.png

    Basically, an Atlatl is now Equipment rather than a weapon. Thus, once built into the .mod file and loaded within FGU it does not work the same.

    Images explain this better.
    GCA4 Atlatl equipped in inventory results in this on the Ranged weapon tab:
    GCA4 Ranged Atlatl.png


    GCA5 Atlatl does not show up at all because once again, it is only considered equipment. However, if you have Atlatl Darts or Javelins, now it gets interesting.\
    Javelins and Atlatl Darts.png


    So a Javelin is different in GCA4 verses GCA5. In GCA5 the ammunition item (at least in this case) carries the information pertaining to the Atlatl "Mode". Atlatl Darts however, are the same in either version because they can only be used with an Atlatl which I guess goes without saying.

    What this means is in GCA5 if you purchase an Atlatl it won't show up as a ranged weapon.
    Also, it means that if you buy a Javelin, it would show the possible "Mode" of being used with an Atlatl, even if you don't own one!

    In GCA4 you would only see the option of using a Javelin with an Atlatl IF and ONLY IF you owned and equipped an Atlatl.

    While I'm sure most people are probably not using an Atlatl, I can't help but think there must be other items that could have a similar result.

    Is this a bug with the Atlatl in GCA5 or is this how it should be?

    I've been chewing on what to do about this but it'll take some extra effort to make this work like it did when we were using GCA4 and I'm not sure it's worth it. What do you guys think?

    edit: Well, I wanted the images to show in the thread but they seem to open individually for me so hopefully ya'll can figure it out.

    edit2: Stupid me, did an update and smoked my exporter. Rebuilding...better...faster..stro..
    Last edited by Jaxilon; June 14th, 2022 at 23:42.

  5. #145
    @Jaxilon, I have this error now on your GURPS MM.

    The attachment is a screenshot of what happened when I try to import a GCA5 .txt file export. I have no XML exporter available for GCA5 as no one would tell me where that is coming from. In your video in how to import from GCA5 tutorial, you have an option called "XML Exporter". That option alone does not show up on mine. It only shows the PC or NPC Export option
    Attached Images Attached Images
    Last edited by t3xx3r; July 31st, 2023 at 17:47.
    Proud Fantasy Grounds Ultimate Licensee/Game Master with text only games

    Active Campaigns

    Warhammer Fantasy Roleplay 2E: A World Aflames

    Call of Cthulhu: Adventures of Davion Falconia

    Campaigns Planned

    Aliens RPG: Frag 'em, Mag Reload! (A Colonial Marine Campaign)

    Cyberpunk RED: Get Geeked, Corpo! (A Night City Adventure against the Mega Corps)

    Fallout 2d20: New Orleans

    GURPS: Prism International (Inspired by Rainbow Six)

  6. #146

    Join Date
    May 2013
    Location
    East Coast USA.
    Posts
    957
    Quote Originally Posted by t3xx3r View Post
    @Jaxilon, I have this error now on your GURPS MM.

    The attachment is a screenshot of what happened when I try to import a GCA5 .txt file export. I have no XML exporter available for GCA5 as no one would tell me where that is coming from. In your video in how to import from GCA5 tutorial, you have an option called "XML Exporter". That option alone does not show up on mine. It only shows the PC or NPC Export option
    Check your update options on GCA5. I think there is an export for FGU.

  7. #147
    Yes, I checked. I updated the GCA 5 and added the FGU exporters. Both are for PC/NPC. I have gotten into touch with Armin, the developer for GCA 5, and he said that when he has time, he will work on the simple XML exporter Jaxilon used in his video. The simple XML exporter will export XML files and help make it readable for the GURPSMM. He said that the reason behind the problem of the XML file, currently as it stands with GCA 5, is that the XML exported now are complex. His GURPSMM cannot read the complex XML file now; only what was found in legacy GCA 4.
    Proud Fantasy Grounds Ultimate Licensee/Game Master with text only games

    Active Campaigns

    Warhammer Fantasy Roleplay 2E: A World Aflames

    Call of Cthulhu: Adventures of Davion Falconia

    Campaigns Planned

    Aliens RPG: Frag 'em, Mag Reload! (A Colonial Marine Campaign)

    Cyberpunk RED: Get Geeked, Corpo! (A Night City Adventure against the Mega Corps)

    Fallout 2d20: New Orleans

    GURPS: Prism International (Inspired by Rainbow Six)

  8. #148

    Join Date
    May 2013
    Location
    East Coast USA.
    Posts
    957
    Quote Originally Posted by t3xx3r View Post
    Yes, I checked. I updated the GCA 5 and added the FGU exporters. Both are for PC/NPC. I have gotten into touch with Armin, the developer for GCA 5, and he said that when he has time, he will work on the simple XML exporter Jaxilon used in his video. ...
    Thanks for your efforts, and sorry for not understanding your problem.

  9. #149
    Last time I was using this I had to modify the exporter GCA5 used. Unfortunately, to do this I had to replace the existing one with my updated version and every time GCA5 updated it would replace my version. Maybe the optional update to use GCA4 xml covers this now. I haven't messed with it for a while.

    edit: So what I mean is I took a look at the plugin WoodsmanX made and created an exporter that works with my ModMaker. However, GCA5 didn't seem to allow for other 3rd party plugins so I had to rename mine the same as WoodsmanX's which replaces it. Hence, why every time GCA5 updates it overlays my plugin with the original.
    Scrap what I just said - I took another look at it and it seems I'm the Space Monkey. Once I named it correctly, GCA5 handles it just fine. I can probably share this with everyone but I'm not sure if I have to do anything with the copyright stuff. Because I'm just piggy backing on WoodsmanX's work mine still has his information in the copyright tags. So, now that I think about it I'm just confused. I'll go take a look at that part now under his project and see if there is anything I need to follow. Up till now, I was doing it for myself.
    Attached Images Attached Images
    Last edited by Jaxilon; August 3rd, 2023 at 15:32.

  10. #150
    Quote Originally Posted by Jaxilon View Post
    Scrap what I just said - I took another look at it and it seems I'm the Space Monkey. Once I named it correctly, GCA5 handles it just fine. I can probably share this with everyone but I'm not sure if I have to do anything with the copyright stuff. Because I'm just piggy backing on WoodsmanX's work mine still has his information in the copyright tags. So, now that I think about it I'm just confused. I'll go take a look at that part now under his project and see if there is anything I need to follow. Up till now, I was doing it for myself.
    Jaxilon,

    I requested that from Armin Sykes, the developer behind GCA 5. I have tried out the GCA 5 with equipment and firearms. It works beautifully for GCA 4 Import. However, your program fails to populate items found in Advantages/Disadvantages or Skills so I don't know what exactly to do at this point. Hopefully you will be able to find a way to make it work to have everything populated correctly for GURPS 4E.
    Last edited by t3xx3r; August 4th, 2023 at 02:41.
    Proud Fantasy Grounds Ultimate Licensee/Game Master with text only games

    Active Campaigns

    Warhammer Fantasy Roleplay 2E: A World Aflames

    Call of Cthulhu: Adventures of Davion Falconia

    Campaigns Planned

    Aliens RPG: Frag 'em, Mag Reload! (A Colonial Marine Campaign)

    Cyberpunk RED: Get Geeked, Corpo! (A Night City Adventure against the Mega Corps)

    Fallout 2d20: New Orleans

    GURPS: Prism International (Inspired by Rainbow Six)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
DICE PACKS BUNDLE

Log in

Log in