Page 1 of 2 12 Last
  1. #1

    Will Fantasy Grounds (non Unity version) support macOS Catalina?

    Hello!

    macOS Catalina apparently is dropping support for 32bit binaries.

    Currently in macOS Mojave, I get the warning that “Fantasy Grounds is not optimized for your mac, contact the developer for a patch” in recognition of the likelihood of it not working once 32bit support is dropped.

    I really like the new features in Catalina and would like to upgrade to it when it is released.

    Other than the obvious FGU launch, are there plans for Fantasy Grounds (classic) to be supported in this 64bit only environment?

    thanks!

  2. #2

    Join Date
    Apr 2008
    Location
    Virginia Beach
    Posts
    2,978
    Nothey wont invest the significant effort to do that. They tried but abandoned it because some of their libraries are incompatible with 64 bit

  3. #3
    I made the mistake of upgrading to the beta version of Catalina and FG doesn't work at all. When you attempt to open FG it doesn't even appear on the dock. Nothing happens.

    I've been wanting to remove the beta off this Mac anyway, so now I have a good reason to finally do it.

  4. #4
    You might be able to use an alternate solution like Parallels to install FG on a Catalina machine.
    Or maybe the Wineskin devs (or someone else) will write a 64-bit wrapper than can run 32-bit Windows applications.

    At this point, we don't have the resources to rewrite all the components to make FG Classic run in 64-bit; so we're focusing on getting FGU out instead.

    Regards,
    JPG

  5. #5
    damned's Avatar
    Join Date
    Mar 2011
    Location
    Australia
    Posts
    18,866
    Blog Entries
    1
    Wineskin will not solve this issue.
    If you upgrade to Catalinas you will not be able to run Fantasy Grounds without something like Parrallels.

    MoreCore - Generic Ruleset
    --- Projects ---
    Extensions | Tutorials | MoreCore | MoreCore Themes | Call of Cthulhu | Maelstrom | FG Con

  6. #6
    The latest version of wine is 64 bit and I’ve run FG on it, but I am running macOS High Sierra. Dustem you can install the latest version of wine and see if FG will run with the macOS beta.

  7. #7
    damned's Avatar
    Join Date
    Mar 2011
    Location
    Australia
    Posts
    18,866
    Blog Entries
    1
    Quote Originally Posted by dmbrown View Post
    The latest version of wine is 64 bit and I’ve run FG on it, but I am running macOS High Sierra. Dustem you can install the latest version of wine and see if FG will run with the macOS beta.
    Having not done it before, but based on everything I could find - the emulator AND the app need to be 64bit...
    It will be good to see if dustem can test it with a 64bit emulator and confirm either way...

  8. #8
    Quote Originally Posted by dmbrown View Post
    The latest version of wine is 64 bit and I’ve run FG on it, but I am running macOS High Sierra. Dustem you can install the latest version of wine and see if FG will run with the macOS beta.
    But not on 10.15?

  9. #9
    Yes, I am not running 10.15. You could download the latest version of wine, which is 64bit and see if you have any luck installing FG in it and getting it to run.

  10. #10
    Quote Originally Posted by dmbrown View Post
    Yes, I am not running 10.15. You could download the latest version of wine, which is 64bit and see if you have any luck installing FG in it and getting it to run.
    I just tested on 10.15 with wine64, I'm getting a "Bad EXE format" error which often means incompatible architecture.

    I have another threat on the issue here, consensus is basically to not upgrade and wait for FGU: https://www.fantasygrounds.com/forum...on-macOS-10-15

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in