Page 8 of 8 First ... 678
  1. #71
    Kelrugem's Avatar
    Join Date
    Sep 2018
    Location
    Geneva, Switzerland, and Lyon, France
    Posts
    822
    Oh, and by reading the code I saw that the "Shift methode on damage" was not working anymore without causing an error. (With pressing shift while drag&dropping a damage result you could heal instead, that didn't work with my extension though there was an easy workaround)

    That is fixed now, too
    Last edited by Kelrugem; August 2nd, 2019 at 22:26.

  2. #72
    Kelrugem's Avatar
    Join Date
    Sep 2018
    Location
    Geneva, Switzerland, and Lyon, France
    Posts
    822
    To the Pathfinder users: This extension is incompatible with the mirror image handler of darrenan. To make them compatible is easy but then I would have to offer separate new packages and then I loose the overview about my own extensions Would it be okay for you when I implement this into the advanced Pathfinder extension? (but I have to ask darrenan, too) Since not all users probably will read the questions, I would like to try to add a new option into the options about whether one wants to use that extension but I have never done such a thing so it may take some time until I was able to do that option-method. And, as far as I can see, the mirror image handler uses the "remove effects" extension such that I also have to look for a warning message output into the chat when one turns that on without having that extension...

    Would that be okay? I still have to see how to solve that without having another form of packages

    EDIT: For reference the link to darrenan's nice mirror image extension: https://www.fantasygrounds.com/forum...dler-extension
    Last edited by Kelrugem; September 24th, 2019 at 00:20.

  3. #73
    The mirror image extension is great, and I would not like to have to choose between your extension and that one.
    But there is no need to rush anything.

  4. #74
    Kelrugem's Avatar
    Join Date
    Sep 2018
    Location
    Geneva, Switzerland, and Lyon, France
    Posts
    822
    Hi all

    I need some help now from the Pathfinder users who may also use the mirror image handler of darrenan

    I've attached here some test version of the new advanced Pathfinder version, but it is only in this post, not yet in the main post and also not included in any of the packages.

    I tested it and it seems to work but could someone of you test, too, whether this extension is now compatible with the mirror image handler? (because I may not know how to use the mirror image handler and what the use cases are; therefore I rather want to hear from actual users of that extension whether everything works) (and since I never had such a method for making things compatible)

    Download this extension here and open a new campaign with that extension and the mirror image handler loaded (and the remove effect extension which is needed for the mirror image handler) and then test whether the mirror image extension works for you also test whether your targets with concealment are removed after a failed miss chance roll (which is a feature of my extension but may normally be overwritten by the mirror image handler; beware that this also depends on your RemoveOnMiss choice in the options)

    Thanks in advance I hope that works, I may or may not then remove all other packages and code them similar as this extension such that packages are not needed anymore. But I am not sure yet if I will do this because all users of these extensions are now used to that procedure and I do not know how to communicate a possible change in such a way such that everyone knows about that
    Attached Files Attached Files
    Last edited by Kelrugem; October 8th, 2019 at 06:06.

  5. #75
    darrenan's Avatar
    Join Date
    Jul 2011
    Location
    Sammamish, WA
    Posts
    974
    If it would be easier for you, feel free to incorporate the Mirror Image functionality into your extensions. I'm assuming Mirror Image works differently in 3.5?

    Also be aware that the Mirror Image extension relies on the Remove Effect extension that also has the STACK: functionality in it.

  6. #76
    Kelrugem's Avatar
    Join Date
    Sep 2018
    Location
    Geneva, Switzerland, and Lyon, France
    Posts
    822
    Quote Originally Posted by darrenan View Post
    If it would be easier for you, feel free to incorporate the Mirror Image functionality into your extensions. I'm assuming Mirror Image works differently in 3.5?

    Also be aware that the Mirror Image extension relies on the Remove Effect extension that also has the STACK: functionality in it.
    Thank you very much

    I will think about that, at the moment it seems that my new way of solving compatibility issues works, too, so I may not need to incorporate your extension or to make a separate combined extension My extension does not need the remove effect extension and therefore I wanted to see if I can make it compatible without incorporating your extension. I basically did this with an if-clause checking whether your extension is loaded and the code is then different when your extension is activated. In that way everyone can decide if one wants to use the mirror image handler, too I've increased the loadorder of my extension to make sure that your extension will be loaded earlier (about the 3.5e users: it's is also in that code though the mirror image is different in 3.5e, there is no near miss removal of mirror images and the images can spread out a bit; but I've put the compatibility code also there when someone wants to use the Pathfinder version instead )

    But thinking about that more: I could also incorporate your extension and make a similar if-clause checking whether the remove effect extension is loaded. Hm, I will see what I will do at the end

    Thanks again for your help

  7. #77
    Kelrugem's Avatar
    Join Date
    Sep 2018
    Location
    Geneva, Switzerland, and Lyon, France
    Posts
    822
    In the main post you can now find the 3.3.9 update There are the following fixes and changes:
    • Now compatible with the Mirror Image handler of darrenan But it is not incorporated, so load the mirror image handler separately when you want to use it
    • Stable effect will be now also automatically removed when lethal damage is incoming (when you're dying and you have stabilized)
    • Added the damage type bleed. With that you can now code bleed damage: It overcomes DR and is similar to such special damage types like critical, i.e. wearing an axe with DMGTYPE: bleed will result into damage types slashing and bleed, not only bleed
    • The visibility of the chat message of fortification depended on the attacker which is not useful. The fortification rolls of players will now be shown while the ones for NPCs will only be shown when the settings of the GM are allowing this
    • Drag&Drop of numbers from the little modifier box into the wound entries in the CT or character sheet were not working anymore due to my code of fortification. This is fixed now
    • The drag&drop into the nonlethal box in the character sheet didn't respect resistances versus nonlethal damage type (in the native FG code). I now added this Pro tip (independent of this extension): Using e.g. /mod 5 [TYPE: fire] results by the way into a dragable 5 which respects resistances versus fire, similarly change the damage type and number to get other macros (do not use such a thing with an attack) Similarly this is possible with other typical things you see in the chat like [HEAL] and so on; but be careful this is surely not an intended feature of FG, I just find that funny that this works, too
    • Updated to FGU

    I am allowed to incorporate the extension about automated flat-footed, thanks to Mr900rr The extension is not up-to-date for FG and I will incorporate this into my AoO extension due to arising incompatibilities. So you will find this feature then in the packages where AoO is included if you want
    Last edited by Kelrugem; November 16th, 2019 at 09:02.

  8. #78
    Kelrugem's Avatar
    Join Date
    Sep 2018
    Location
    Geneva, Switzerland, and Lyon, France
    Posts
    822
    New upload of the extension because I now made one extension of both versions, this will make everything easier for me at the end But important: You have to re-toggle this extension (or one of its packages) in your campaign extension list since it has a new name (advanced 3.5e and Pathfinder), untoggle the old one (very important!) and/or delete your old advanced effects extension (or the packages) I hope this is not too unconvenient for you, for me the updating is then much easier

Thread Information

Users Browsing this Thread

There are currently 3 users browsing this thread. (0 members and 3 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in