You would be able to open the module associated with the product, but you won't be able to use the extension that accompanies it. It would need to be configured to work in both PF1 and PF2