FGU Twitter Sweepstakes
Page 14 of 18 First ... 41213141516 ... Last
  1. #131
    This is a super-useful (especially for spells!) extension and in my humble opinion, should be part of the base package.

    The 3.3.4 debug version works in FGU, except if you open the NPC list. It then gives an error saying something like divide by zero, and no entries appear in NPC. If you try it again, it locks up FGU.

  2. #132
    Minty23185Fresh's Avatar
    Join Date
    Dec 2015
    Location
    NV, USA
    Posts
    806
    Blog Entries
    29
    Quote Originally Posted by Howell View Post
    I love this extension but one issue I'm having is that when the extension is enabled I can't add new items to any list (ie. new NPCs, now groups, ect) nor can I drag and drop copies of things from one group to another. Sometimes if I disable the extension and reopen the campaign the new items I was trying to create are there but weren't visible while the extension was running. I'm using FG v.3.3.10 classic
    Quote Originally Posted by Dax Doomslayer View Post
    Howell, I had the same issue which caused me to stop using this. I thought it may be a conflict with another extension or something but didn't take the time to try it out...
    Just by chance guys.. Did you have any filters applied when created the new items? I haven't tried this, but it would make sense that new the items wouldn't show if there were filters applied. The new (empty) items wouldn't satisfy the filter criteria. When you restarted, with filters cleared, the items would magically appear.

    Copies can be tricky. I believe they always go to the “New” group. So if you’re in any other group, say the Princes of the Apocalypse group, then your new copy won’t show up until you navigate to New or All.
    Last edited by Minty23185Fresh; April 25th, 2020 at 03:26. Reason: Added groups comment

  3. #133
    Minty23185Fresh's Avatar
    Join Date
    Dec 2015
    Location
    NV, USA
    Posts
    806
    Blog Entries
    29
    Status update:
    Looking back through the last few pages of this thread, it appears to me as though I have two outstanding issues, PathFinder 2 support and Unity support.

    I'll be tackling the PFRPG2 support first. Initial investigation this morning leads me to believe that, optimistically, PFRPG2 will take me at least a month. The PFRPG2 ruleset has been implemented vastly differently than PFRPG (one), so I can't springboard off PFRPG, nor 3.5E (like PFRPG did).

    I have too many irons in the fire to be able to devote as much time to it as I'd like. After that I'll tackle FGU.

  4. #134
    Just a small thing when using this in my 5e campaigns.
    The first time I open the NPC list I get the below error and no NPCs are listed until I toggle from All to anpother and back again, only the first time though
    Script Error: [string "FFAL/scripts/FFAL_data_library_common.lua"]:468: invalid order function for sorting
    Yes, I am running whole kitbag of other extensions of course!

  5. #135
    Already looking forward to PF2 support. Thanks for status update.

  6. #136
    Minty23185Fresh's Avatar
    Join Date
    Dec 2015
    Location
    NV, USA
    Posts
    806
    Blog Entries
    29
    Quote Originally Posted by mordkhaan View Post
    Just a small thing when using this in my 5e campaigns.
    The first time I open the NPC list I get the below error and no NPCs are listed until I toggle from All to anpother and back again, only the first time though
    Script Error: [string "FFAL/scripts/FFAL_data_library_common.lua"]:468: invalid order function for sorting
    Yes, I am running whole kitbag of other extensions of course!
    Oddly enough, it might not be the “kitbag”. Because it states it is a sort issue, it is probably an inconsistency in the data of a module you have loaded.

    1) what version of FG? Unity or Classic?
    2) since FFAL has been tested with the more common modules (Players Handbook, DM’s Guide, Xanathar) and I don’t have the others it is likely not one of those three.

    You stated that things are okay after you toggle the Group. I suspect this is not true. The NPCs are loaded but the data is probably not loaded into the individual fields. Or at least not sorted.

    This leads me to wonder, are you really using FFAL? Or is it important to you to have a big “kitbag”? If you peruse the FG forums long enough you’ll come to realize, big “kitbags” only invite problems. It is in your best interest to run FG with the least number of extensions possible, only those that you really need. Community developers, like me, write our extensions in a vacuum of what other developers are doing. If two programmers have extensions that modify behaviors of a specific area of FG, the chances of a conflict are high. FFAL fiddles with the Recordset Libraries, the data that everything else in FG depends on. Chances are extremely high that, with the more extensions you have loaded, the greater the chances you’re going to have problems. Personally, I only use FFAL when I am developing content: migrating a pdf module to an FG .mod or writing my home brew. It is extremely rare that FFAL is running while I am DMing a session. And it’s MY extension!

    That said, it’s your call. And FFAL is having an issue so let’s see if we can get it straightened out.

    1) Start FG with your whole kitbag of extensions, unload all your modules and open the NPC Recordset. Does the error occur? (It shouldn’t there is no data, if it does there is an extension conflict.)
    2) Add a module, start with a known good one (from above, PHB, DMG, or XGE). Open the NPC Recordset, does the error occur?
    3) If not, right click down in the drop down combo box area for the radial context menu. Choose the reload data option, it’s at about 9 or 10 o’clock, I think, on the menu. Does the error occur?
    4) Repeat steps 2-4 until you get the error.
    Then let me know what module caused the error.

    If the error occurred with no modules loaded or only one of the guaranteed modules, then it’s a “kitbag” issue and the same procedure has to be repeated but with extensions being loaded one at a time instead of the modules.

  7. #137
    I had wondered about the module list so will work through that
    The kitbag is mainly the Twohy and co lot

  8. #138
    I will just add that I am also seeing the same behavior as Mordkhaan

  9. #139
    Minty23185Fresh's Avatar
    Join Date
    Dec 2015
    Location
    NV, USA
    Posts
    806
    Blog Entries
    29
    Quote Originally Posted by dimfuture View Post
    I will just add that I am also seeing the same behavior as Mordkhaan
    Okay. Fair enough. But this is not helpful and gives me nothing to help find out what is causing the problem.

    See post #136, I’ve provided specific steps to go through to help localize the issue. Once I have something concrete I can go on from there.

  10. #140
    When I open NPC's or click on any of the buttons at the top of npcs I also get errors. FGC

    Script Error: [string "FFAL/scripts/FFAL_data_library_common.lua"]:168: bad argument #1 to 'floor' (number expected, got nil)
    Ruleset Error: windowcontrol: Database type mismatch for control (cr) in windowclass (reference_groupedlist_groupitem)
    Script Error: [string "ref/scripts/ref_groupedlist_groupitem.lua"]:58: attempt to index local 'cField' (a nil value)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
DMsGuild

Log in

Log in